XML Configuration File Generator export fails to upload to zero config


#1

Hello everyone,

I’m trying to use the XML Configuration File Generator tool from grandstream in order to create 750 extensions and import the xml files to the ucm but when i import one of the exported files on the ucm it outputs the error “the file contents are formatted wrong”. All the devices are going to be GXP1630 so i downloaded the appropriate file from the config template from the tools section in grandstream and configured the CSV file with MAC addresses and sip . On the tool i have inputed the config file on the Configuration Table, selected the Output path and after selecting the CSV file i push “Run with CSV as input” even though the files are created when they are imported we get the error “the file contents are formatted wrong”. Link to the files: https://www.dropbox.com/s/37cnfhpk9os9ois/gxp_template.zip?dl=0


#2

I’m sorry, is there zero config that allows you to make them all fast and use that tool?


#3

A few questions:

  1. When running the tool and creating the XML, did the tool generate any errors?
  2. When importing into the UCM, where was the import function performed?

I suspect you may have used the wrong import location in the UCM. Go to zero-config and look for:


#4

Hello ,

  1. The tool doesn’t generate any errors.
  2. As show in the picture this is where i go to upload the xml files “Choose File to Upload”

#5

I suggest you submit a ticket to support with the files so they can take a look.


#6

I don’t know this tool, you intrigued me and I tried, actually it’s a mistake to me too.


#7

That “import” is to upload the CSV file, not the XMLs.

You use the mentioned tool if you are using a simple Web server instead of the ZeroConfig of the UCM.

Unfortunately you have to build the templates from scratch (well your settings options from dropdown menus or P-value lists) on the UCM to use them with ZeroConfig.


#8

Hello @cyfo

Do you have such a template for me to see how to begin?

Thanks in advance.


#9

It was supposed to be something like below but I tested it really quick and was rejected too:

mac,model,ip,version
000b24556677,GXP2130,192.168.9.9,1.0.1.1

#10

precisely, accepts them only xml, but by in all cases error


#11

@cyfo I have tested your suggestion and you alos mention it doesn’t work
@damiano70 unfortunately some say it needs xml some say csv it’s not clear i’m still trying to find out


#12

we shouldn’t be the ones to find out, but the parent company should make the instructions public.


#13

A lot has been said, so I thought I’d throw a little in.
Sounds like you want a generated config file to work in zero config.

Config files can be made in bulk with the generator, but won’t work in zero config.
The Generator and zero config are 2 different ways to provision phones.

I made a video on the provisioning tool if that helps:


#14

Hello @lstutesman i saw your video and it helped to understand what the XML Configuration File Generator does and it will not help me with zero config as you said. Although i cannot upload these at the ucm at all i can only upload them to the phones. What is the purpose of the file upload though in the zero config?What type of files do we upload there?


#15

show me the screen you are referring to?


#16

@lstutesman i suppose you refer to the screen of the file upload in the zero config? These are the images



I have tried uploading the xml files here but they fail, i have tried the suggested format of a csv file from @cyfo
from post 9 and several others i could think as well as the MAC.csv file that includes MAC address and configuration from the XML Configuration file Generator zipped file that is offered as a test file like it’s shown in the video but no luck as well.


#17

I also tried different combinations of the CSV to no avail. I guess a support ticket is needed then, since together we have tried a lot of different combinations.


#18

On page 100 of the User Manual you see the following:


#19

Hello @drostoker this has already been tested and suggested from @cyfo at post 9 and it doesn’t work unfortunately. Maybe it’s the encoding. If you have tested this and it works could share a link with the document?


#20

Sorry @athevolveo, I didn’t recall.

I did try the exact example from the manual and got the “The file contents are formatted incorrectly” message as well.