Wrong time on GXP16xx after Daylight Savings Time change


#21

I didn’t write that it didn’t work well, I just wrote that you’re putting it in the wrong format.
probably this is the correct one -> 0.pool.ntp.org


#22

I went back to the phone GUI and did some testing,. I have a couple of 1630s at a client site which is not connected to a UCM. They are running 4.132 and another with 4.128 firmware. I am in the central US timezone. I have the phones set to a valid NTP server as it does pick up the time, but as other have noted, they are an hour off. Instead of 7:00PM, they read 6:00PM.

If I go into the Web GUI and change the time to a different time zone, the displayed time will change. In my initial try, I changed the timezone to US Eastern. The display changed from 6:18 (should have been 7:18) to 12:18AM. I then changed it back to central time and it changed to the correct time of 7:18PM. I then altered it back to Eastern and this time it displayed correctly. I changed it back to central and again the display showed correctly,

However, if I reboot the phone, it will revert back to being an hour off. I am uncertain of the refresh time, but I suspect it will revert back to being an hour off when it does. I will check it again and see.

in the meantime, it certainly appears to be an issue in the firmware and how get a time and references it back to the timezone for display.


#23

This is clearly a bug.

I’m having the same problem.

Everything appears to be configured correctly, but the LCD has the time one hour off; 21:30 and should be 22:30.
If I log into the phone’s web interface, the Status page displays the correct time.


#24

Changed P64…

was:
<P64>EST5EDT</P64>

Changed to:
<P64>customize</P64>

<P246>EST+5EDT+4,M3.2.0,M11.1.0</P246>

Now the correct time is being displayed on the LCD.


#25

I submitted a ticket on the matter. They suggested to use the manual self-defined solution in the meantime while it is being evaluated. The sense I got is that they recognized the issue.


#26

I had a similar issue recently with Central time. Got the same response. I then tried the other two Central time options and found one that worked. Didn’t make sense to me as to why I had to use the one I did.

Ticket 20190326224538

FWIW.


#27

I have the same issue on GXP1782, 2140 and 2170. I use the 3CX official template and they are not sure if it is a config or a firmware bug.