Wrong time on GXP16xx after Daylight Savings Time change


#1

Once again my GXP16xx phones are not reflecting the correct time. All of my GXP22xx and the PBX reflect the correct time .

How do I keep these phones updated?


#2

What are they using for the NTP server? I assume that they are still showing standard time?Additionally, what firmware version? In looking at the release notes, there have been a few updates that address some of the time issues and perhaps one of these do the trick.

I had the same issue yesterday, but changed the NTP server and the firmware at the same time (made the UCM the NTP server as it had the correct local time) and one or the other or both fixed the issue.


#3

I would have checked the firmware as well, but remember that my GXP2240s are all on the correct time. Just the GXP1630 are off by the 1 hour.

As requested:

PBX - 1.0.18.13

GXP1630 - 1.0.4.132


#4

And the NTP server?


#5

The IP of the PBX … sorry


#6

Just to be certain @vic45708, you have turned on the UCM feature to be a NTP server (it is off by default).


#7

Yes … NPT is turned on

Under System Settings -> Time Settings
Under Global Policy -> Localization -> Time and Date

As well as I added the settings in the Model Template and sent an update to the 1630s.

Localization -> Time and Date

NTP -> PBX
zone -> -6:00 CST
Self Defined :: MTZ+6MDT+5,M3.2.0,M11.1.0

This has been an issue for some time twice a year … only on GXP16XXs

It will clear out when the old rule takes effect.; Meanwhile all of my customers are confused.


#8

You have told the system to use NTP. You have not turned on the Time Server Feature of the UCM which makes the UCM a NTP server.

.


#9

If the time zone is not working correctly in your model/firmware, then select the “self-defining” option since that one is correct on your snippet for central time. The self-defining one is more reliable.


#10

The NTP Server did not work. I did reboot the device [1630] to confirm.

Please help me with “self-define” as I have the string on the Model Template under Localization -> Self-Defined


#11

I’m using a GXP1630 and the DISPLAYED TIME (what’s on the LCD Screen) is off by an hour while the SYSTEM TIME (shown on the Status Page) is correct

using us.pool.ntp.org

FW 1.0.4.132
All other Grandstream models (GXP17XX, 21XX) are fine only an issue w/ GXP16XX


#12

@ericwp This is exactly what I am experiencing and having to deal with it twice a year. Once again I’m hoping for a workaround.

Thanks for the confirmation!


#13

I was having the same issue with several clients who use the 16xx phones. What I did was change the PHONE to use the Self Defined time zone and put in CST+6CDT+5,M3.2.0/02:00:00,M11.1.0/02:00:00 (I am Central Time), made sure that the firmware was updated to 1.0.4.132, then restarted the phone. At times it took two restarts, but it did finally work.
As for the NTP settings, I did try using the UCM as the NTP server then put the UCM ip as the NTP server at the phone, and tried using pool.ntp.org set at the phone.


#14

I am having the same issue. UCM6208 newly installed in February with all GXP1630 phones.
Morning of March 11th I immediately noticed the time was off, and I have been getting complaints ever since.

I first checked the UCM - System Settings/Time Settings/NTP Server and it is Enabled.

I next checked the UCM - System Settings/Time Settings/Automatic Data and Time.
It is using pool.ntp.org with both DHCP Option 2 and 42 checked and time zone “GMT-05:00 (Eastern Time)”.
I did some googling and changed it to ‘Self-defined Time Zone’ with a value of ‘EST+5EDT+4,M3.2.0,M11.1.0’
Reboots of UCM and my phone made no difference in the time on the phone.
I wasn’t originally aware I could see the time on the System Status/System Information screen, but I figured out the UCM had the correct time all along from the timestamps in the event log …old and new entries are correct before and after the TZ change.

So then I went to UCM - Value-added Features/Zero-Config/Global Policy/Localization.
Enable NTP is check and set to Enabled.
NTP Server is checked and set to the UCM’s IP address.
Time Zone is checked and set to ‘GMT-05:00 (Eastern Time)’.
Enable Daylight Saving Time is checked and set to Enabled.
There is NOT an option to specify and user selected time zone on this screen for the phones to use, so otherwise it all seems right to me.

Looking at my phone’s screen I found the Status/System Status/IP Geographic Information screen shows Time Zone as ‘EST5EDT’ which sure seems right to me … from others reporting uses with this series of phones and mixed old and new DST information in Grandstream documents I’m almost wondering if the phone will change its clock on the old date in April … If I don’t solve this I guess I’ll find out.

I then logged directly into my phone’s web interface.
BTW, It forced me to change the admin password … what a PITA as I won’t remember it … I wish I could push one and only one into all the phones if it really needs to be different, since I’m not going to do it manually.
Under Settings/Preferences/Date and Time.
It has the UCM’s Ip for the NTP Server.
It shows Option 42 as allowed (Yes).
Time Zone was ‘GMT-05:00 (Eastern Time)’.
Allow DHCP Option 2 was checked.
I tried playing with the DHCP Options allowed and reseting the phone and that only seemed to screw it totally up, so I put them back.
Unlike in Global Policy, I was able to pick a Time Zone of ‘Self Defined Time Zone’ so I did, and used the same string (EST+5EDT+4,M3.2.0,M11.1.0) as I used on the UCM.
After rebooting my phone again it did show the correct time on the screen.

I betting the phone’s firmware has the old or wrong definitions for DST rules, at least for North America.

So, since there isn’t a way to specify a custom time zone in global policy it seems like I have to manually change every phone … which is possible since I only have a couple dozen but a major PITA (I can’t imagine the headache if I had LOTS of phones). Also this is something that will have to be done every time I add a new phone, which is NOT Zero Config … I really liked (past tense) the just plug it in and it boots up ready to roll.

Would someone at Grandstream please fix the firmware for these phones and or allow Global Policy to set a Self-Define Time Zone.


#15

We just rolled out our system. Most phones are GXP2140’s and the time is correct on those. The two GXP1630s that I have are off. I’ll be trying the solution that @ScottS posted above to hopefully fix the issue.

Just wanted to add my name to the list to show that the GXP1630 issue is NOT an isolated one in my opinion.


#16

All …

It’s nice to know that we ALL share the same issue with the time zone change. You will notice in a week or so when the OLD time zone rule kicks in, the phones will update on their own. You will also notice that these phones will have a relapse in the fall, when we FALL BACK!

@ScottS … It is a PITA to have to log directly into each phone. Unfortunately for me I have 16 systems with the GXP16xx phones in place and all of them are off. Don’t forget what happens when phones are reset to factory. The bad part is my customers do not feel that they should be paying for a support call as this is really a GRANDSTREAM issue. So now my service time is consumed and expended without compensation.

I don’t know if anyone with GRANDSTREAM monitors this forum. I have not sent a request to tech support for assistance, but it seems redundant to do so. Most of the other manufacture forums are monitored by Manufacture Support.

Please not that this is not the only issue with this otherwise really great product. I would only hope that someone could address the products inability to accept commands from the Global policy and eliminate the need to modify Model templates or modification of individual units for something that should be handled Globally.

Assistance Requested …


#17

Aha … thank you @vic45708 for mentioning “Model template”!
I hadn’t played with that at all so looked it up.
I then created a model template for the GXP1630, made it the Default Model Template and Active.
Then in Options picked both the Time Zone and Self-Defined Time Zone fields under Localization/Date and Time.
Then set Time Zone to Self-Define TIme Zone.
Then set Self-Defined Time Zone to ‘EST+5EDT+4,M3.2.0,M11.1.0’ as I’d done manually to my phone.
Saved.
Reset one phone … it went back another hour … now off by 2hrs!
Rebooted the phone, and after it came back up was as 7pm on 12/31/1969 for quite some time, but finally switched to the correct time!
So I then rebooted all the phones … I haven’t check them as yet, but sure hope the problem is now fixed for me … at least for this specific model phone, if/when we buy another model I’ll have to remember to check if I need to create a model template for it or not.


#18

@ScottS … did the model template work for you? When I place the http://pool.ntp.org/ as the NTP server, it does not update the phone.
Are you filling in all 3 fields or only the Self Defined?


#19

that NTP server is incorrect, this is an example of a correct NTP server -> ntp1.inrim.it


#20

My Global policy sets the NTP Server for all phones and when logged into my phone’s UI it was getting that value so there was no need to set it in the Model Template. I used the IP of the PBX, which is configured to provide an NTP server, because all my phones are internal so I saw no need for each phone to be hitting the internet. FYI, my firewall is configured to only allow the UCM to get out and only for very select protocols (like NTP) and to very specific IPs (like my SIP Trunk provider).
When I used the UCM to reboot all the phones quickly one after the other many of them were 2 hours behind when I checked them as if they only did a reset (like my first attempts with my phone). Rebooting them one by one with some time in between each seems to make them come up correctly.
BUT, when checking the phones and asked the employees I was told anecdotally that their phone used to be off by 1h 4min or the like, so maybe the NTP for the phones isn’t working so they are drifting over time … my system has only been in use since February 10th.
So possibly I have an NTP issue, but the time zone issue appears to be solved.

@damiano70 According to https://www.ntppool.org/en/ “The pool.ntp.org project is a big virtual cluster of timeservers providing reliable [easy to use] service for millions of clients.” It is what I used on the UCM and on all my domain controllers and their clocks all stay in sync and match my cell phone year over year, so it does work fine in those places. I can’t say if it would work for a phone as I didn’t try it.