Why is GS Wave such a battery hog?

bug

#1

I was shocked at how much GS Wave chewed up the battery on my iPhone X when I left it running in the background! Is there anything one can adjust to reduce its power consumption? It’s easily 3 times as bad as Bria, which I can leave running all the time with negligible effect on my battery level.


#2

Yes, run it in TCP mode instead of UDP mode. That will help a lot, if you can do it. Otherwise, you can also change the NAT keep alive timeout, which is a big battery drain, and you can disable its ability to run in the background and answer calls when you’re not using it. Not ideal, but it helps.

Our Wave apps are actually better than Bria with some fine tuning regarding battery usage, but mostly, it’s switching to TCP.


#3

GS Wave uses SIP, that’s why. SIP is a dialog-based protocol and the client and server have to be in semi-constant conversation.

We have all of our customers using Cloud Softphone by Acrobits. It uses PUSH instead of SIP. So, the app can be completely closed for days, and you’ll still get every inbound call without any battery usage whatsoever. Free to our customers, costs us near-nothing to provide it, and the app is pretty powerful combined with our automatic provisioning system.

I met the CEO at a trade show in Florida last year, they’re a really cool company.


#4

CloudSoftphone sounds like an interesting option, but I don’t think the problem is directly attributable to the SIP protocol. If SIP was the main problem, then Bria would be just as much of a battery-drainer, but it is much much less of a drain than GS Wave.


#5

I’ll try TCP instead of UCP and see how it goes. Thanks!


#6

Bria uses Push as well, it’s on their site - at least for the most recent version. I’m not sure they always had push.


#7

Just a quick followup. I switched my UCM6202 and GS Wave app to both use TCP rather than UDP, but it seems like GS Wave is still consuming MUCH more juice than Bria. I like the way the GDS3710 is supported in GS Wave, but it’s not a viable option if the app in the background is responsible for nearly half of my overall power consumption during the course of a day.


#8

@SmartVox, You mind going in to detail regarding the fine tuning of the settings you do with Wave?


#9

Exactly what I said:


#10

Hello,
I did have changed from UDP to TCP and 3/4 of my battery capacity was lost overnight.
I have find out that Grandstream wave is still running on background when I close the app. I have to force the app to close from the app android menu to end my battery draining. I did not find option so that Grandstream does not run on the background when the app is closed. It would be really great if this option existed. Is it your android option not the app option? My android does not have this option.

I did found “Start on Boot” option in the “Advanced settings” menu.
I have found “NAT traversal options” under the “Network Settings” by a SIP account.
However the available options are: NAT NO, STUN, Keep-Alive, UPnP and auto.
But no keep alive timeout settings. When I tried NAT NO, incoming phone calls did not work after a while, but I do not know the exact reason. Maybe the STUN could help if it works properly.

It would be great if the Grandstream wave would have more options about registering/incoming SIP calls as this is problematic when travelling.
Many of our customers use VoIP on mobile phones mostly only for outgoing calls. They can for example call with their office phone number when outside a office. Or use VoIP for a better price. When at home or in office, it is better to use hardware VoIP phones for incoming calls. When they are out, it is often problematic to receive calls as the internet quality may be not good enough and may change when on the move - for example when travelling by car/bus/train. So forwarding to mobile number is better when necessary.
However before making outgoing call, it is not problem to stay on the place with known good internet quality. Also the battery drain problem is not present.

Please is there any other way how to use Google wawe only for outgoing calls ? The only way I have find out is to kill the app after each call so it does not stay on background.

The Grandstream wave seems to be the best VoIP app so far, however unlike Zoiper or CSIPSimple this option for only outgoing call is missing. Killing the app after each call is not good option.