When I use the "#" at the beginning of the connection the call does not complete


my telephone system uses a password to be able to make external calls in this case, the code “#” is used after a 6-digit password that is distributed to each employee, and after that the external number is used, for example: " #736482 11 998887760" when “#” is used, the connection does not complete, and in the call history it indicates “N/A”!


Would you please explain what this is:
example: " #736482 11 998887760"

You said " the code “#” is used after a 6-digit password " , so why is the # the first character in your example?



the code is a function of the company’s telephone system where I work, the “#” code and the 6-digit password is the way the employee uses it for external calls, internal calls do not need this code and password.


the code “#” at default is used to transmit send the digits - you need to modify the dial behaviour on the profile page.

Check the manual out at:


if I activate this function, the phone calls the previously dialed number. example: I called the number “1515” an extension used internally in the “RH” sector if I try to call an external extension after calling the HR previously using “#5151 11 94144134” the grandstream does not identify the password and number dialed, grandstream only identifies the “#” code and automatically redials


Kev is telling you to disable the function of using # as dial.

Additionally, have you modified the HT dial plan to allow the use of a # in a dial string? You can see in the snippet that Kev posted where it shows the default dial plan and you will note that it does not currently allow #, assuming it has not been modified.


yes, I changed them, it’s no use


as soon as I use the “#” code it redials, and the rest of my dialed number simply disappears when I use the call history on the web system that ht812 provides.


I modified yes and performed several and several tests, without success


You need to disable Use # as redial in the settings. The manual has the details.

Scottsip already advised of this earlier in the thread.


when I disable it, it really doesn’t redial, but the code “#” still doesn’t appear in the call history, and because it doesn’t appear, it doesn’t make the call


as soon as I put the “#” and the password with the number I want to call, the phone keeps making a sound as if I had disconnected a call


Then get the manual and look up how to use SIP file so you can see the contents of a SIP trace and see what the messaging has.


I will try


I’ve been comparing some problems that were occurring with other users here in the forum, and I’ve been testing some changes in the dial plan, after I added “#x.T” I managed to make the calls normally, thanks for the help.


the result was like this:


it’s working for now, I don’t intend to change it


The actual should be #x+ and the T is optional, but I don’t argue with success. Glad it’s working

The # is a special digit much like using * for dial codes, it has to be specified to be allowed.
The x indicates a digit (0-9)
The + indicates that one or more digits (i.e., at least 1 digit)
The T is optional in that it indicates to automatically initiate the dial string if no further input is received after 3 seconds. Otherwise the interdigit timeout of 4 seconds (default) will cause the dial.
The . is a wild card for characters (one or more)