What is the host extension for affinity? USABILITY!


#1

The first screen of the affinity software is mostly empty and asks for a ‘host extension’ without any explanation. There is lots of room for this. (by the way: the software itself does not even show its name on the first screen.) What does CTI App mean? I did not find any explanation for this acronym. Please let someone lecture your stuff.

The manual states:
“Enter the host’s extension registered”
I did already know that I need to do this. It´s there right in the dialog field.
This manual does not tell my anything!
What does that mean?? I can´t find anything called ‘host extension’ in the web based phone configuration. Why? It is a webpage with lots of space for the documentation the user needs and some kind of useful guides. Why do you create a ‘manual’ that actually tells nothing?
It’s even worse if I use the interface in my native language, German.

On the ‘advanced’ screen of the affinity software I can enter the Host Address. So I enter the phones IP address and try to discover and connect it. Which results in nothing. Is this what is supposed to happen? I can ping the phones IP address and access it via webbrowser.

Seems I need to use this ‘host extension’ that is capt as a secret.

PLEASE DO USABILITY TESTS!
The web based configuration is confusing. Everything is somehow called settings except the preferences which are hidden somewhere in some other settings. Please do some usability engineering!
Check out the tooltips!! 99% of these give absolutely no additional information! They just add the word ‘enter’ to the same label that is already displayed 3 times!! Look at this option:
PPPoE Service Name [_______]
which provides the tooltip:
PPPoE Service Name
Enter the PPPoE Service Name

is? that? supposed? to? help? anybody???

Please let someone evaluate the accessibility of your products! The affinity software uses light gray text on white background, which is VERY hard to read. Also there are texts that use wrong or all-capital letters which reduce readability. The phone display sometimes shows very very tiny texts, for example when flashing firmware or rebooting or so. There might be people who can´t read this and restart the phone, even if these messages should prevent exactly this.

Please make sure that your manuals / documentation actually describes your products.
I tried to configure the location for the weather screen. The setting has to be like ‘Berlin, DE’ not ‘Berlin, Germany’. Even the wrong information is not present in the phone´s own configuration dialog.

Please do real life usability tests with your website.
Check your analytics and logfiles what problems users experience navigating it. The search does not find products if the name is entered with a space. Use fault-tolerant search. What could I want if I enter “2135”? Could be your phone with this product number. I don´t know or care that your search expects me to enter GXP or GPX or GXP-2135 or something else!

Please use descriptive texts instead of just “IMPORTANT UCM61xx

Please name your files in a way that your users might find plausible and do it consistent! Like: “Grandstream GXP2135 Users Manual - German - 2019-03-05.pdf” If everything starts with ‘grandstream’ and the product number, all the downloads are nicely ordered on my harddrive. Currently I get files like “gxp2130_gxp2140_gxp2160_gxp2135_gxp2170_quick_user_guide_german.pdf”. Do you think that any of your customers will be enthusiastic if she/he finds this file in 2 years time and might have the slightest idea what this might be, looking at the filename? Sometimes you start with the product name, sometimes in capital letters, sometimes not, sometimes with the document type in front, sometimes at the end of the name,

What is the version of the installed firmware?
Boot 1.0.7.3
Core 1.0.9.93
Base 1.0.9.107
Prog 1.0.9.132
Locale 1.0.9.118
Recovery 1.0.9.97
Which of these number am I expected to compare to the numbers of your download site?
Why doesn´t the phone find the firmware itself? There is not even a link on the phones firmware update page! not! even! a! link!
would you belief that??

All the tools for download you list on your website might be great stuff, but how can I tell? Its just listed in the most unmotivated way possible, using wording like “IP Surveillance Tools GS Upgrade Tool” or “Configuration Template”. If you order the downloads in a meaningful way and give a system how to find what works with my product, add some more descriptive text for what users this tool might be useful, and some screenshots, this might become a very welcome source for added value to your customers. Currently its just irritating and ugly.
Very ugly.

Did I suggest doing usability tests? Hire some usability engineer who will find 90% of all these issues just by looking at them. Very quick and easy and cheap.
Your customers will thank you!

Please read and follow the book ‘designing for the digital age’ by Kim Goodwin. She actually describes the usability engineering of business phones.

Bonus tip: did your support department ever talk to the engineers? You must have loooots of feedback for all the issues.


#2

To get this working, your phone has to support the Affinity “protocol” (it isnt, but will call it that for now). Ive just installed it, worked in seconds, heres what to do:

  • Both the PC and phone MUST be in the same network subnet

  • This WORKS even if the phone is openVPN for the extension (as mine is) but the PC must be in the same LAN segment as the phone (so the UCM in this case would be remote from both the PC and the deskphone that uses openVPN to contact the UCM).

  • The software uses Bonjour protocols from Apple, so if you have ANY network layers blocking this, its likely going to be an issue.

  • In the phone (ive been using the GXP2135, 2170 on firmware 1.0.9.121) go to Network > Affinity, make sure this is enabled with the selected account you want to use

  • Run the software, it shoudl now appear on the screen, if not go to ADVANCED (lower part of the screen) then type the IP address of the phone, this should now find the phone.

  • When adding the phone it will show up a PIN code on the phone you need to enter to the software

The above should get you around most of the issues…


#3

thank you for your answer.

sadly that does not work.
I can ping the phone, initiate the connection via its IP address and get the PIN code displayed on the phone. the affinity software also displays the PIN input, but the only answer I get, is ‘Failed to connect, GXP may be busy’. Even right after a reboot of the phone.

I would like the contacts management feature.Seems I have to go longer ways there.


#4

What network switches do you have?
Turn off the Windows firewall and attempt again