Wave IOs App on iPhone not connecting to UCM 6304


#1

For security reasons I have changed the UCM 6304 ports 8090 to XXXX and Wave port 8089 to ZZZZ.

Wave App did not work on Android or IOS, what port does it look for by default?
Wave Lite Android did work when manually setting the port to ZZZZ.

Question 1: Is there any way to get and install Wave Lite for IOS to manually set the ZZZZ port?
Question 2: Is there any way to get Wave App for IOS to work with the ZZZZ port?
Question 3: Any alternative IOS app to use with to Grandstream UCM 6304?


#2

Fix your router ACL and make sure that it is only known IP addresses that use remote connection to the UCM then you will not have many problems.


#3

Dear user,

Thank you for using the Wave application! You can change the Wave port to another one and you may need to use the updated port when logging in the Wave client, otherwise you cannot log in your extension. Please note that the Wave Lite application is EOL. May I ask what kind of issue you encountered after updating the port? You can recording a short video, share some screenshots, and export logs from your Wave app and send them to us for troubleshooting. Please note that Wave app is only working with UCM63xx SIP server, and other apps may not use all features in UCM63xx. Thanks for your testing!

Thank you!


#4

I have been trialling Groundwire.
Paid app. A lot of settings.
Best of all it does BLF.


#5

Dear user,

Thank you for using the Wave application! Wave also supports the BLF feature. You can try it and let us know if you have any questions. Thanks for your testing!

Thank you!


#6

They are 2 APPs with completely different technology and not comparable:
Groundwire.is a generic, paid SIP APP
WAVE is an APP of another technology, WebRTC, proprietary to Grandstream, and supports BLF, free


#7

Thanks for your supplement and comments, Damiano!

Please let us know if you have any further questins about the Wave app. Thanks!

Thank you!


#8

image
image
image
image

After scan the QR code, just clic on register, failed.
Tried changing the port and/or domain to public IP on http/https, can’t get registered.

It does work on Android Wave Lite when we manually set the update port at SIP port and the public IP (without port) at SIP server.


#9

Were u able to login before changing the ports?
Are u able to login on local network https://IP:zzzz?
You can enable collect logs on wave mobile or export logs from wave desktop and check what causes this error


#10

‘ucm_config’ user: ‘ucm12345’ host: ‘localhost’ (Got an error reading communication packets)


#11

What communication packets are you referring to?

Were u able to login before changing the ports?
Are u able to login on local network https://IP:zzzz?


#12

That is the log I got in Syslog at the moment I tried to register on Wave IOS.
I didn’t test Wave IOS before changing ports.
Yes, I can locally access to the UCM by 192.168.1.70:XXXX and Web Wave by 192.168.1.70:ZZZZ
And remotely access by public IP to UCM 20x.xxx.98.1x3:XXXX and Web Wave by 20x.xxx.98.1x3::ZZZZ


#13

Dear user,

Thank you for your feedback! Please kindly provide the exported logs from your Wave application and send them to us for troubleshooting. Please note that if you are trying to log in through the RC domain address, you do not need to put the port following the address. Thanks for your testing!

Thank you!


#14

image


#15

Thank you very much!
I was sending UCM log instead of Wave log because I didn’t find it


#16

Replaced the actual Public with aaa.bbb


Send Message: 2023-9-21 14:49:29
REGISTER sip:200.aaa.bbb.143 SIP/2.0
Via: SIP/2.0/TCP 192.168.1.129:39551;branch=z9hG4bK278427983;rport;alias
From: sip:162@200.aaa.bbb.143;tag=583915079
To: sip:162@200.aaa.bbb.143
Call-ID: 1410830049-39551-1@BJC.BGI.B.BCJ
CSeq: 2000 REGISTER
Contact: sip:162@192.168.1.129:39551;transport=tcp;+sip.ice;trickle-ice;reg-id=1;+sip.instance=“urn:uuid:00000000-0000-1000-8000-000B8227F948
Max-Forwards: 70
User-Agent: Grandstream Wave Android 1.0.23.10(HUAWEI MAR-LX3Bm,Android 10)
GS-APPID: eBQMU-dnR6CdtWmpzPw7Ow:APA91bFVa1JhwbRsV9sAgsDTl4ZTich6AJzU0BfcS9Cz8ChanwTEVnOPVTKP-n0_-XXoqwkudK7qmWfHeqdbOWA-3U0th_9ER2EJOlNux1lJXmOGOW2UZE72wKXLSRQuKQvjNwE9wztA
Grandstream-type: GSWave mobile
Supported: path, x-gs-config, x-gs-state, x-gs-conf-invite
Expires: 3600
Allow: INVITE, ACK, OPTIONS, CANCEL, BYE, SUBSCRIBE, NOTIFY, INFO, REFER, UPDATE, MESSAGE
Content-Length: 0

Send Message: 2023-9-21 14:49:50
REGISTER sip:200.aaa.bbb.143 SIP/2.0
Via: SIP/2.0/TCP 192.168.1.129:51507;branch=z9hG4bK265733838;rport;alias
From: sip:162@200.aaa.bbb.143;tag=583915079
To: sip:162@200.aaa.bbb.143
Call-ID: 1410830049-39551-1@BJC.BGI.B.BCJ
CSeq: 2001 REGISTER
Contact: sip:162@192.168.1.129:51507;transport=tcp;+sip.ice;trickle-ice;reg-id=1;+sip.instance=“urn:uuid:00000000-0000-1000-8000-000B8227F948
Max-Forwards: 70
User-Agent: Grandstream Wave Android 1.0.23.10(HUAWEI MAR-LX3Bm,Android 10)
GS-APPID: eBQMU-dnR6CdtWmpzPw7Ow:APA91bFVa1JhwbRsV9sAgsDTl4ZTich6AJzU0BfcS9Cz8ChanwTEVnOPVTKP-n0_-XXoqwkudK7qmWfHeqdbOWA-3U0th_9ER2EJOlNux1lJXmOGOW2UZE72wKXLSRQuKQvjNwE9wztA
Grandstream-type: GSWave mobile
Supported: path, x-gs-config, x-gs-state, x-gs-conf-invite
Expires: 3600
Allow: INVITE, ACK, OPTIONS, CANCEL, BYE, SUBSCRIBE, NOTIFY, INFO, REFER, UPDATE, MESSAGE
Content-Length: 0


#17

Dear user,

Thank you for your feedback! You can send a private message to us with complete trace file and syslog, so that we can troubleshoot this issue based on the complete capturing.

You can also try the solutions below:

  1. Please ensure that the “TLS Enable” option has been checked on the Web UI of the UCM63xx and the TLS port has been configured correctly.
  2. Please check if the NAT configuration and external address have been configured on the Web UI of your UCM63xx.
  3. After configuration, please make sure that you have clicked the “Apply” button on the Web UI of the UCM63xx so the updated configuration can be applied to the UCM63xx.
  4. Please ensure that your local network can connect to the TLS port of the UCM63xx.

Let me know if you have any updates. Thanks!

Thank you!


#18

IT WORKED! TLS set, now it is working!

Thank you!


#19

Dear user,

Thank you for your feedback! Let us know if you havd any further questions. Thanks!

Thank you!