Wave continues to be unusable on Iphone


I had previously been posting tickets about this but will try making a topic . I have been testing the GS Wave for IOS, and on several different Iphones of various but recent models including iphone ! and 12, if the app is not maximized, or if the phone is asleep and you receive a call, when you answer it appears that the call is answered on the Iphone, no sound, but to the caller is just continues to ring. This includes the very latest version that came out recently. It may occasionally work but in the vast majority of cases you cant answer a call, making the app not useable. There are also problems with transfer


Have a many issues too on both versions (ios and android). Waiting for next release. According to a long time is took for the next release there are lot of changes are coming.


Same, I have issues here and support wants me to do a bunch of captures, I am not putting the user through testing on there end… Wave Web/ Windows and Android Work decently enough, iOS seems to have issues.

Waiting for the next release, hopefully soon?


There are other alternatives that work well with a SIP extension - eg Zoiper / Bria / 3CX which all work on cell / mobile phones. Consider those as options rather than the gswave product until it is refined enough for production environments.


Any idea when a new iOS version will be available to address the incoming call/background call no audio issues?


Dear user,

Thanks for using Wave application! We plan to release the next Wave iOS version in late October to improve the audio performance which will fix the “no audio” issue in this case. Thanks for all your testing!

Thank you!


Good to hear, thank you for the response, I look forward to the release!


No problem! Let us know if you have any further questions about this.

Thank you!


Will this version address the app not.connecting an inbound call if the app does not have focus (for instance when phone is asleep) /


Dear user,

Thank you for your feedback! We added some audio improvements in the Wave application next release to fix the inbound/outbound call “no audio” issue for Wave iOS, and we also improve the pushing notification function in the Wave Android/iOS which may fix the issue you mentioned. You can try it in the Wave next release in late October. Thanks for your testing!

Thank you!


HI there is a new version and unfortunately still not fixed at all.


Dear user,

Thank you for your feedback! This version may not include the fixes I mentioned in my last post. Please wait for a few weeks and we will release a new version at the end of October. You can give it a try with the release at the end of October. Thanks for your testing!

Thank you!


My frustration is this - I am doing presentations that show features like softphone that really aren’t that important to the development team and costing me sales. The old wave app worked, and over a year ago they replaced it with an app that still to the day does not have basic call functionality. I am a software developer, and if this was my team I would have expected to be fired at least 6 months ago. They should have whoever did the old app implement the telephone part of the new wave app.If somebody was seriously working on this app it would not take a year!! By the way previous to last Dec 24 the new wave app worked ok for phone calls!!


Dear user,

Thank you for your feedback! Sorry for the incovenience and I have passed this issue to our Wave iOS developing team today. Our Wave developing team will try to improve this issue asap in the next release. In order to ensure this issue will be fixed in the next release, could you kindly help to reproduce this issue again and capture the logs from UCM63xx and Wave iOS application and send to us for troubleshooting? Please ensure that both logs are captured in the same test case. Thanks for your testing!

Thank you!


Here are new traces




And here is log of another problem, I can open separate topic if you want. Problem description. We have UCM and Grandstream phones connected through remoteconnect. When I call the wave app and try to transfer to another working extension on my UCM it says "I am sorry that is not a valid extension



The app does not work well enough to merit extensive testing, these are the first 2 things i tried and both fail


Dear user,

Thanks a lot for your testing! For the Wave iOS app no audio issue, may I ask if this issue can be reproduced only under background mode/device sleep mode? Or, you can reproduce this issue randomly? We checked your given logs and it shows the TURN/STUN server address is unreachable, we want to check if the TURN/STUN server address has been configured correctly? If this issue is a random issue for you, could you kindly help to capture another trace file with syslog which is under normal working scenarios?

For your 2nd question (Call Transferring issue), could you kindly help to capture the trace file with syslog in the UCM device side? We need to check the issue from the server side. Thanks for your testing!

Thank you!


I am replying to your latest questions.
1 - The main complaint I have been complaining about is that the phone shows the call but it cannot be answered. I dont know why you keep saying no audio issue. It usually has audio but sometimes does not, I cant get enough calls to find out.
-2 you say the app could not contact the Stun server. Please see my screenshot of the RTP settings on the UCM, the Stun server is there, and the phone was configured via QR cord, how do you modify it?
3- if you look about I posted UCM logs at the same time I posted the Wave logs for the transfer problem.

I am happy to provide anything that would help, but I feel like nobody really pays attention to my posts. I have posted these problems on support and sent many times


Dear user,

Thank you for your feedback! I have passed the information to our Wave development team for evaluation. I will get back to you once we have any conclusions. Thanks for your testing!

Thank you!