VOIP Trunk(ViaTalk) Incoming calls not coming through UCM6202


#1

New UCM6202 user and having difficulty setting up my VOIP trunk(ViaTalk). Analog lines working fine, but voip inbound calls are having issues. Previously came from a freepbx box that worked completely fine. For some reason, inbound calls into the VOIP trunk will get a “you’re not allowed to dial this number”. Trunk status says registered. TIA.


#2

Your not allowed to dial this number is, as far as I know, an error message that is delivered when an extension owner of the PBX is attempting to dial to a destination and they not have the needed privilege or possibly a time constraint is engaged.

I assume you have inbound rules generated and that you know what the format of the DID is and in which field of the SIP INVITE the number is located and have set the DID mode in the UCM’s SIP trunk to use that field accordingly.

What does the inbound rule look like (provide a screenshot)?


#3


Hope this helps.


#4

Here is my Sip Trunk settings:


#5

the correct string is “x.”

The single “x” as it appears in the screenshot is telling the system to only accept a DID with a single digit of between 0-9.

The “.” following the “X” is telling the system to accept 1 or more digits following the initial X (0-9), so virtually take ANY and ALL number(s) of any length and send to your ring group.

If you have more than 1 DID or will in the future, you will need to qualify the DIDs so that the system is able to discern if there is more than one route (different destination) so the “wildcard” setting you have now won’t hijack it and send to the ring group as you have shown.


#6

Problem is x.
Simple account often do not have numeric user accounts.

If you good then catch packet on incoming call and check request and To field.
See what PBX sent to you there.
Set one you want to use (trunk advanced -> DID mode)

If you not good
Try as pattern Username from trunk (and try both did mode)


#7

Switching DID mode to “To header” did the trick. Thanks for the help guys.


#8