VOIP.MS with HT812


#1

Did anyone had success setting up VOIP.MS with HT812? I can’t even get it registered. All my softphones are working fine on my network.


#2

probable DNS problem, instead of the FQDN try to enter IP on the registration server


#3

I have tried to no avail. Multiple IP addresses.


#4

While the question is pointed, it remains to be seen that a response will be forthcoming as it relies on someone having had success specifically with the HT and VoIP.ms.

So, rather than waiting on the affirmative to the question, let’s understand what it is that has been done so far in the effort -

  1. Have you looked at this guide? While not specific to the 812, it is for the 802 and the function of the registration aspect is the same.
    https://wiki.voip.ms/article/Grandstream_HandyTone_802_-_HT802
  2. You mention softphones which may or may not complicate matters as it is an unknown as to what the devices are sitting behind in the way of a firewall and how connected - Wi-Fi or cellular? Further, if Wi-Fi and thru the same NAT firewall, if they may be using the same ports that the HT is and what the firwewall PAT table is doing with the traffic. Are you trying to use the HT and softphone at the same time and to the same VoIP.ms account?
  3. Is the public IP where the HT is located static or dynamic? How is NAT being handled at the firewall (port forwarding) and how is the HT set to let VoIP.ms know what that public IP is, so that VoIP.ms know what public IP it should use when communicating back?

We can start with the above to understand the situation and go from there.


#5
  • Have you looked at this guide? While not specific to the 812, it is for the 802 and the function of the registration aspect is the same.
    https://wiki.voip.ms/article/Grandstream_HandyTone_802_-_HT802
    Yes I have, even the helpdesk at VOIP,MS could not help me. They could not detect any incoming traffic. I tried to put the device to DMZ but it did not help either. My 2 softphones work without a glitch, and they are on the same network and subnet. My Wi-Fi id not separated from my LAN network.

  • You mention softphones which may or may not complicate matters as it is an unknown as to what the devices are sitting behind in the way of a firewall and how connected - Wi-Fi or cellular?
    Wi-Fi, I have turned off cellular.

Further, if Wi-Fi and thru the same NAT firewall, if they may be using the same ports that the HT is and what the firwewall PAT table is doing with the traffic. Are you trying to use the HT and softphone at the same time and to the same VoIP.ms account?
I have tried to use at the same time and also alone.
Tried with same account and sub account.

  • Is the public IP where the HT is located static or dynamic? How is NAT being handled at the firewall (port forwarding) and how is the HT set to let VoIP.ms know what that public IP is, so that VoIP.ms know what public IP it should use when communicating back?

It is Dynamic using ADSL. I am not sure how would VoIP.ms would no my Public address. When used their helpdesk they could see my IP address bur could not see any traffic coming from it.
[/quote]


#6

OK, so -

  1. Disconnect the softphones. We do not want them to interfere.
  2. Find and disable SIP ALG in the router.
  3. Assign a reservation in the router or DHCP server so that the HT will always have the same IP address.
  4. Port forward port 5060UDP from the Internet to the reserved IP of the HT.
  5. Port forward port 5004-5010UDP from the Internet to the reserved IP of the HT.
  6. Log into the HT using the reserved IP assigned, and set up using the credentials provided by VoIP.MS for username, authID and password. Also setup the SIP server and proxy as provided by them for the server to be used.
  7. Set the network traversal method to STUN
  8. Enable SIP options Keep alive and set to 30 seconds.
  9. Set unregister on reboot to Yes. (this is a change)
  10. Set the local SIP port to 5060 if not already (this coincides with the router setting earlier)
  11. Set the local RTP port to 5004 if not already (this too coincides the router setting earlier).
  12. Set SIP register header uses - to WAN port
  13. Set enable call features to no.
  14. Set enable Allow SIP messages from SIP Proxy only to yes (prevents ghost calls)
  15. On the basic or advanced tabs, there will be a field by which you will see STUN Server. Enter “stun.ipvideotalk.com” without the quotes in this this field. (the STUN server will detect what the public IP is and then because you told the HT to use the WAN port, it will insert your then current public IP into the contact and connection header to VoIP.ms. This is how VoIP.ms will know how to respond back to your HT, no matter what IP it has at the time).

16 Remove the settings from the softphones, The router will only route to the HT now that port 5060 is there and it is unknown how VoIP.ms would react to multiple devices trying to register to the same account at the same time.

17 Reboot the HT and then see if it registers. If so, then try calls.


#7

I am coming late to the game here, so please excuse me if I’ve missed anything.

  1. Are you running the current firmware?

  2. Can you connect to the HT’s web interface?

  3. What are you connecting the HT to and what do they connect to?

  4. If you can connect to the HT’s web interface, what IPs are being assigned to each?

  5. Have you tried setting the HT up on GDMS? If so, does the HT show as online or offline?

Please note the following from the Admin Manual

Accessing the Web UI

  • Via WAN port
    For the initial setup, the Web access is by default enabled when the device is using private IP and disabled
    when using public IP, and you cannot access the Web UI of your HT812/HT814 until it’s enabled

Via LAN port
Please refer to steps below if your HT812/HT814 is connected via LAN port:

  1. Power your HT812/HT814 using PSU with the right specifications.
  2. Connect your computer or switch directly to your HT812/HT814 LAN port.
  3. Open the web browser on your computer.
  4. Enter the default LAN IP address (192.168.2.1) in the address bar of the browser.
  5. Enter the administrator’s password to access the Web Configuration Menu.
  6. Make sure to reboot your device after changing your settings to apply the new configuration.
    Note: Please make sure that your computer has a valid IP address on the range 192.168.2.x so you can
    access the web GUI of your HT812/HT814.

#8

I have tried to no avail. Still it can not register. See attached.


#9

@Odszulu you do realize that

  1. What you posted is very difficult to read/manipulate; please post more smaller screenshots in future, and

  2. You did not post the Basic Settings, which may provide key information to assisting you.


#10

Trying to set up device on GDMS, but system is busy error message keeps on coming up. Sent them feedback, waiting for response.


#11

Sorry about that, but it is working on my end when I use Edge, also posted basic settings.


#12

Device added. StatusAbnormal Abnormal?!


#13

And where did you enter the username, authid and password?


#14

Thank you for this. Now if you could only answer my other questions.


#15
  • Are you running the current firmware?
    Program – 1.0.17.5 Bootloader – 1.0.17.1 Core – 1.0.17.1 Base – 1.0.17.3
    CPE – 1.0.1.137

  • Can you connect to the HT’s web interface?
    Yes

  • What are you connecting the HT to and what do they connect to?
    Telephone and a FAST2864_v6851E router

  • If you can connect to the HT’s web interface, what IPs are being assigned to each?
    only one internal IP assigned

  • Have you tried setting the HT up on GDMS? If so, does the HT show as online or offline?
    I did, it is online, Account Status is Abnormal.


#16

Under the FXS PORTS tab.


#17

I was asking what was connecting to each port on HT…

Try this:

  1. Change the device mode to WAN only in the HT basic page
  2. Plug the a network cable from the LAN to the WAN
  3. reboot the HT


#18

I only used one port, and it is connected to the router. Changed the basic setting and rebooted. Still can not register. device status is still online.


#19

And that is the LAN or WAN port?

What IP is the router giving the device; I have found it usually best to provide a static IP to it.


#20

Sorry again, it is in the WAN port. 192.168.50.18, made on IP reservation on the router, but if you think I can change it to static.