VoIP cannot send out or receive a call. Using GrandStream HT812 ATA. Phone port never registers


#1

I have tried to describe the problem I’m facing. The VoIP cannot send out or receive a call. I have an analog phone connected to a GrandStream HT812 ANA (RJ12). The GrandStream LAN port is connected to the LAN port of a laptop with wireless capability (RJ45). The GrandStream WAN port is connected to a Hitron CGN3U WiFi Gateway (or modem) with an RJ45 cable. The Hitron CGN3U modem is connected to an apartment building coaxial cable.

The internet connection works. The Hitron CGN3U has the correct LEDs on. The GrandStream HT812 does not have blue LEDs on for the phone ports. The HT812 blue LEDs are on for the LAN and WAN ports connecting the laptop and the Hitron modem. Trying to dial out results in just silence. There used to be a busy signal for any number I dialled. I made a configuration change to the Hitron modem to disable an SIP ALG setting. This was recommended on another website as an issue that caused various VoIP problems. This change eliminated the busy signals for dialing out, and is now replaced with no noise.

I can access the configuration web-sites for both the GrandStream HT812 and the Hitron CGN3U. I also have the technical PDFs for these models. The technical support for the carrier has helped about as much as they can. (I cannot phone them which they wanted me to do.) One of their technicians thought that the Hitron modem was somehow blocking SIP packets to the Grandstream HT812. Or that the Grandstream HT812 has a self-configuration problem.

What I have tried in way of technical support suggestions are these things.
GrandStream HT812: A seven second pin reset. A reset by entering a MAC address through the phone menu (IVR). The device reboots but the phone LEDs do not come on. I’ve tried the pin reset about 12 times. The MAC reset 3 times.
This is the website configuration page. I can never get a Registered status for the phone port. I have entered my phone number for the user id (using 9’s here).
This was recommended in the manual.

GrandStream Device Configuration, Status page

Product Model: HT812
Serial Number: 207GJV6K6104628A
Hardware Version: V1.6A Part Number – 9610005016A
Software Version: Program – 1.0.10.6 Bootloader – 1.0.10.2 Core – 1.0.10.2 Base – 1.0.10.6
CPE – 1.0.1.106
Software Status: Running Mem: 25536
System Up Time: 19:08:00 up 1:06
PPPoE Link Up: Disabled
NAT: Unknown NAT
Port Status:
Port Hook User ID Registration
FXS 1 On Hook 9999999999 Not Registered (I have entered a 10 digit phone number for the user id)
FXS 2 On Hook Not Registered
Port Options:
Port DND Forward Busy Forward Delayed Forward
FXS 1 No
FXS 2 No

Provision: Not running, Last status : Downloading file from url.
Core Dump: Clean

I cannot get the GrandStream HT812 to register an FXS Port.

This is from the FSX Ports configuration page.
User Settings
Port SIP User ID Authenticate ID Password Name Profile ID Enable Port
1 999999999 999999999 Yes

2 	  					

I’ve entered my phone number for the SIP User and Authenticate ID and clicked on Enable Port Yes.

This is the PROFILE 1 configuration page or part of it.

Profile Active: Yes
Primary SIP Server: 123.456.7.10 (e.g., sip.mycompany.com, or IP address)
Failover SIP Server: (Optional, used when primary server no response)

The Primary SIP Server is obtained from the phone menu (IVR, Enter ***, 02) and the profile set to active.

Despite making these configuration changes to the GrandStream, the Status page will show the FXS Port as Not Registered. The blue LED light for the phone will not be on.

If anyone has any suggestions I would be interested. I’m close to just calling it quits. Thank you.


#2

Can you load a softphone (free) on a PC and register with those settings? Confirm no firewall issues.

On the HT812 check the SIP headers as well, I have had to disable privacy headers etc for outbound calls in the past.


#3

Thank you! I am trying out your suggestions. Sincerely–Gary


#4

The VOIP phone is working. The trick seems to have been this: rebooting the Hitron CGN3U modem, followed by a pin reset of the Grandstream ANA. Much to my astonishment the LED light came on for the phone port on the ANA. I think a necessary condition was disabling the SIP ALGs on the Hitron modem.
A strange side-effect: Can no longer access the Grandstream configuration web-page. The password is no longer accepted. I wanted to photograph whatever settings were now successful. Oh well.
Another unpleasant surprise was being issued someone else’s phone number! That took two days to resolve. Apart from that, a wonderful experience.
I hope this might help someone else. Thanks for the suggestion made by RichardW.