Voicemail to EMai, Office 365, Not working - UCM6104 v 1.0.13.14


#1

I recently updated to firmware version 1.0.13.14. Since then Voicemail to Email has not been working. In settings->Email Settings, we had “TLS” checked off, the Office 365 server name is “smtp.office365.com:587” and we have the Enable SASL Authentication checked off. When setting up the smtp account for Office 365, we used the Powershell to ensure that the password does not expire. I use the same SMTP login with a fax machine (received faxes get forwarded as e-mails) and it works fine, so I know the issue is with the IP PBX. The UCM6104 IP PBX for some reason cannot send the e-mails with the voicemails via Office 365, since the update. Prior to it, it worked fine. I tried switching the SMTP account to a GMail (google apps… rather not have to use google apps as we have all our e-mail accounts set up with Microsoft Office 365) account and there it works fine. Really strange. Wondering if anyone else experienced the same issue or knows a fix. Meanwhile sending the e-mails via the Google app smtp login.


#2

Same issue here and at several customers, Office 365 just doesnt work anymore, no more voicemail to email and irate customers.

Have tried all manner of settings to no avail.


#3

Same issue. Tried everything I can think of. Tried switching my office UCM to gmail. That doesn’t work either.

Everything comes back as bounced, deferred or 530-5.5.1

Lots of ticked off clients


#4

[quote=“iKonectU, post:3, topic:18442”]Same issue. Tried everything I can think of. Tried switching my office UCM to gmail. That doesn’t work either.

Everything comes back as bounced, deferred or 530-5.5.1

Lots of ticked off clients[/quote]

If you use a gmail address you must go into account security and “allow less secure apps”.
I use gmail and it works great.


#5

You’ve got to tweak some things in the UCM. I’ve attached a screen shot of my settings. In previous iterations of the UCM firmware, you had to enter :portnumber after the smtp server. This iteration drops that requirement. No body told me to change the settings, during the upgrade, my email just stopped working.

I hope that help!

Regards,


#6

Office365… I opened a ticket with GSS, sent my settings and a trace.
There is a patch for 1.0.13.14 that specifically addresses the Office365 email settings. Applied the new patch and it works

“Please use the following build to upgrade the UCM to. It carries a patch that is specifically used for office365. It is based off the same 1.0.13.14 firmware. Use the link below to download. Extract the fw.bin file and upload to the UCM: http://jax.grandstream.com/mromero/ucm61xx_1_0_13_14_office365.rar”.

NOTE: SASL Authentication must be enabled

Much thanks to Miguel Romero in support!


#7

Thanks! Installed the patch and Voicemail to EMail with Office 365 now works.


#8

I was getting “deferred” with Gmail after upgrading to 1.0.13.14.

That was with Server = “smtp-relay.gmail.com:587

Tried Server = “smtp-relay.gmail.com” (without the :587) but still not working.

Tried Server = “smtp.gmail.com” but still not working.

Changed Server to “smtp.gmail.com:587” and it finally started working.


#9

As an FYI, the new beta firmware lists one of the bug fixes as resolving the O365 mail issues. I have not had a chance to load it on my test unit yet but for the fact it is listed as a resolved bug is a fairly promising statement.


#10

None of these tricks have worked for me. This is extremely frustrating!

  1. Customer is setup on Office 365
  2. Attempted email server setup with his account settings for Office 365
  3. Saw that latest firmware had a fix. Upgraded to the latest firmware. Still nogo.
  4. Changed email server from smtp.office365.com:587 to 587, ticked TLS with and without, ticked SASL with and without.
  5. Everytime the message says sent successfully to test email. No logs and no email on the other end.
  6. Tried the gmail route.
  7. Same scenario tried smtp.gmail.com:465, 587 and with just smtp.gmail.com . Tried with and without TLS. Tried with and with out SASL. Still nogo. I also ticked of the allow less secure apps. no go.
  8. Again on logs just the message that the email test sent successfully.
  9. What is the next option?

#11

I’m not even going to try to explain why or what happened. Like you, we host our mail at Office365. This problem was driving me bonkers for a year for our users, not able to get their voicemails as an email attachment, until today, Sept 1, 2017.

I decided to upgrade the UCM6102 from firmware version 1.0.13.14 to version 1.0.14.23. Then, through time-consuming trial-and-error, I discovered the following worked for me:

TLS = (Enabled, checked)

Type = Client

Email Template Sending Format = HTML

Enable SASL Authentication = (Enabled, checked)

Username = (your Office365 email address)

Password = (your Office365 email password)

Display Name = (Your Name used in “From:” field)

Sender = (Your email address used in “From:” field)

Once you make these changes, click to SAVE. Then click to APPLY Changes. I did not have to Reboot the UCM.

Then click on the “TEST” button. After a minute, Check “Email Send Log” and match up to the system time. You should see,

Send Result = sent and,

Return Code = 250

Next, perform a test call from one extension phone to another, and leave a test voicemail. Assuming you’ve already configured the user’s email address under “Extensions,” then after a minute, look again in the Email Send Log. You should see the same positive results. Obviously, ask that user to check his/her email for the audio attachment.

Hope this work for you guys. Let us know your findings.


#12

do we still need to put the port number after the server name? My email was not working until I did so. Want to double check, thanx
@costwisewpg