Voicemail not Activating on Inbound Calls from VOIP Trunk


#1

I have setup voicemail successfully on the UCM6301 and this works when calling an extension with voicemail activating after the set delay of 30s. However when calls come inbound from the VOIP trunk the voicemail does not activate - the call just terminates after 30s.

I suspect this is a setting I’ve missed somewhere but can anyone suggest why this might be happening?


#2

What happens if the call is answered? Will the call last 45 or more seconds? If not, then a Nat issue.


#3

Looks like that’s the problem. I thought I’d tested this previously but inbound calls are ringing the chosen extensions but on answering nothing is heard and the caller phone continues to ring.

What would cause this? I’ve tried altering various settings on the VOIP trunk without success.


#4

If your UCM is sitting behind a router/firewall, then turn the trunk settings off.

In System Settings, SIP Settings and NAT, input your static public IP or FQDN, then check the SDP box and at the bottom of the page input your local LAN segment. These settings are used to help the UCM formulate the message to the remote device based upon the remote device IP. If the IP is not one from the local LAN, then the UCM will tell the remote device to use the public IP or FQDN. If the IP seen is local, then it will tell that device to use the UCMs private IP.


#5

Yes the UCM is sitting behind a Ubiquiti USG. Where do you switch off the trunk settings? Is this on the UCM or Firewall?

The IP from the ISP is dynamic not static so cannot set a static IP or FQDN. SDP box already checked.
Have altered the other options but without a static IP from the ISP will this work?


#6

In the trunk settings in the UCM.

My suggestion is to obtain a static from the provider as this is foolproof. Otherwise you can use STUN or DDNS.


#7

No way to use static IP as the ISP provider is mobile network behind CGNAT. No access to landline broadband or fibre here so mobile data connection is the only option and you can’t have a static IP or use DDNS with a mobile connection behind CGNAT.

Previous to the UCM we used an HT801 and this worked perfectly.

Where in the UCM are the trunk settings to switch off? Sorry if this is obvious…


#8

Have you read the manual or even looked at the trunk settings to see where that setting might be? Go to VoIP Trunks select the desired trunk and look on the first page.


#9

Yes I’ve spent several days reading, watching and trying to learn this system. I’ve been through that first page under VOIP Trunks and I can’t see an option to switch off trunk settings except the option to Disable Trunk. Hopefully I’ve attached screenshots showing the settings.


#10

Uncheck NAT.


#11

Thank you for your patience and trying to help. I understand the frustration when people don’t try to help themselves.

I did try with NAT off but it didn’t seem to make any difference, with the inbound calls coming in and ringing but when answered the caller phone remains ringing. I will try it again with it switched off.


#12

NAT should be disabled in the trunk settings provided that the UCM is sitting behind a router.
The router and modem should both be checked to insure that SIP ALG is also disabled.
in System Settings, SIP Settings, NAT, the public IP or FQDN needs to be filled in, the SDP box checked and the local LAN segment entered in at the bottom of the page.


#13

All of those settings are as you suggest except I don’t, and can’t, have a public IP as I’m behind CGNAT due to the type of connection.


#14

Then your options are STUN or DDNS using an FQDN.

CGNAT is oftentimes known to impede streaming services as well as VoIP. The best way to describe it is that a need exists for a publicly routable IP.

The UCM knows how to reach the provider, but the provider must be told how to reach back to the UCM. This is done using the settings I described - static IP, STUN or DDNS with an FQDN.

You may also want to try changing the transport to TCP or TCP/TLS rather then UDP, but your provider will need to support it.

And as much as I hate to say it, if the provider offers an analog service, then that may be an option as well.

You can go to maintenance and network troubleshooting and do a capture of a call and send same to me (will PM), then we can see what the messaging looks like.


#15

Thanks to input from @lpneblett I got this working.

I ended up trying a different VOIP provider with better support for SIP Trunks. Both incoming and outgoing calls working perfectly.

Thanks to @lpneblett for all his help :slightly_smiling_face: