VLAN and DHCP

ip-communications

#1

Hi,

I know this question has been asked before but it still doesn’t seem to have been answered for me…

I have a DP715, a freepbx and a ZyXEL SBG3300 router…

On the router I have 3 vlans 1 which is default untagged, 1 which is for guest wifi and 1 which should be for the freepbx/phone…

If I connect a device to the guest wifi the device gets an ip address from the router… if I have a pc untagged it connects to the default vlan and gets an ip from the win dhcp server… ok so far so good…

When I connect the dp715… the dhcp finds an ip from the win server…so I log in to Web gui and change the vlan 802.1q tag to match the vlan id on.the router which I am specifying for voice… reboot phone…

Network led just flashes no dhcp… if I reset phone back onto untagged and then get ip from win server…

There must be a configuration I’m getting wrong or missing… please help :slight_smile:

Jay


#2

It looks good so far. It might be the port where you are connecting the DP715. It should be in a port (from the router or a switch) that has the phone VLAN as tagged and the default one as untagged (this last one is already working for you).

So make sure that the DP715 is connected to a port that actually as access to the desired VLAN. And don’t forget that the phone VLAN also needs a DHCP server, unless you are using static IPs (which might not be a bad idea anyway.)


#3

I have the default one as untagged on all ports on router… the guest wifi as tagged on all ports and same with the voice vlan… the dhcp server for both guest wifi and voice is the router… the default is win server

The only thing I can see based on what you’ve said is there is a dummy switch in between… this is only a test system prior to deployment… I will take the phone straight into the router and see if that then works