Virtual queue saying SIP Trunk username instead of current caller ID


#1

Hi guys,

UCM6202 - firmware v.1.0.20.44

My PBX structure is External Caller–>inbound SIP Trunk–>IVR–>Call Queue–>Virtual Queue,
so when the caller press star (*) which opt the current caller ID to be called back once the agents are available, the system saying SIP Trunk username instead of current incoming caller ID, so is there any way or any trick to solve this issue, please?

Thanks in advance.


#2

if the call comes in on a sip trunk and leaves on the same trunk then it should provide the inbound cli

is that what you are trying to achieve?

What sort of lines do you have


#4

Apologies for the Late Reply,

I’ve got two sorts of lines PSTN and SIP Trunk, I’m not sure whether you exactly get my query or not, because of my bad English I apologise for that.

Anyway, the PSTN is working fine with the virtual queue, but the SIP Trunk is not working properly, let’s say, my SIP username is “09516753322” and SIP password is “xxxxoooo” which is provided by the SIP Trunk provider, so when an external caller (number 023456789) is calling into the SIP Trunk line then jump into the virtual queue, there were 3 options prompt to let the caller press it;

  • “press * to set the callback number to the one you’re currently using”
  • “press 0 to set a new callback number”
  • “press # to continue waiting”
    if the caller pressed * then the system says…
    “your callback number is 09516753322 press # to confirm press * to listen again”
    so the callback number is supposed to be the external caller ID (023456789) not the SIP username ID, that’s ridiculous.
    I don’t know how to fix it up to work properly, do you have any idea?

Thank you.


#5

You need check packets, maybe ITSP sent incorrect contact ? (i guess ucm take number from there)


#6

That’s exactly what I thought initially.

Thank you for giving me an idea.


#7

I’m definitely not an expert but I thought your issue resembled a problem that I just had when I switched to a new SIP trunk service that uses registered trunks.

Go to PBX Settings > SIP Settings > TOS and then uncheck the “Send Remote Party ID” check box.

It’s worth a try. I found that suggestion here. https://forums.grandstream.com/t/firmware-1-0-15-10-for-ucm6301-6302-6304-6308-6300a-6302a-6304a-6308a-released-as-official/51417/4