Video SIP Calls between peered UCMs


#1

Hello fam,
I have two UCMs, 6510 and 6202 peered through an IPSec VPN connection and both run latest firmware.
Everything else work very well, apart from SIP video calls. When I make a video call from 3370s on both sides, the call goes through as an audio call, even though by default the call should be video. I’ve tried direct IP calls and they work fine for video and audio. On both UCMs i’ve enabled SIP Video calls and RTP value is set to one. Ports 10000 - 20000 are also open just in case the RTP Value doesn’t help.
Does anyone have an idea on how to solve this? To make SIP video calls work between two peered UCMs.


#2

Do you have H.264 enabled in the extension’s codecs?


#3

Use a STUN server and make sure underneath Asterisk SIP Settings-Chan_sip-Advanced settings that the custom option videosupport=yes is in there.


#4

You should not need STUN when on a IPSec VPN, The IPs of all are implicit and known to be on a local LAN.


#5

As fmarcoux96 indicated, the codecs in the phones and in the UCM need to match. The payloads also need to match in all as well and if memory serves, the payload for h.264 is 99. I am uncertain what is meant by a RTP value of 1, can you explain?

You should make sure that the bit rate selected for the phones and UCM are the same and supportable across the VLAN as well.

As you are using what I assume to be a site-to-site IPsec tunnel, ports and the like are of no concern as it relates to firewalls and port forwarding.

I assume in each UCMs’ NAT settings you have identified both the local and remote LAN as the local networks on each UCM.

In the extension settings on the UCM, there is a setting for “can direct media”. You can try toggling this setting for both extensions (one video phone must match the other phone, so both yes or both no). If set to yes, the UCM will set up the call (SIP), but the devices will try and set up the media between themselves. If set to no, the UCM will handle both the SIP and media.


#6

you do two things:
1 - on the internal settings of the local ip you have to insert on both the local class and the ip of the peer UCMs
2 - if it still doesn’t work to me the same thing happened and I “solved” it this way -> 201 seat to call 301 seat b and I’m in conversation.
At that point one of the two with the conversation in progress presses the video button. To me so the video started on VPN.

do not use absolutely stun or NAT on the UCM in peer


#7

@fmarcoux96
I’ll check this out tomorrow see if it’s enabled. Most configs are at default.

@lpneblett
I’m doing IPsec Site to Site VPN, everything in one subnet is “local” to the other subnet. At this point, is it okay to ignore the NAT settings?
I’ll confirm this tomorrow, but I think this is enabled by default on the phones as well as UCM out of the box? Regardless, I’ll check.
I will also try out the “can direct media” feature and see if that solves.


#8

Trying to switch to Video mode didn’t work. The GXVs make video calls by default.
The Internal Settings, are you referring to Network Settings page or NAT settings page of UCMs?


#9

remove the predefined video calls (for trial).
you on NAT, below there is a list of local ip, enter the local class of each UCM and also ip of the respective UCM, otherwise UCM activates the nat and makes mess.


#10

@damiano70
Noted. I’ll try that out as well tomorrow.


#11

if you want then send me here or in pvt the screens


#12

@lpneblett
I meant RTP Keep-alive value under pbx-settings/sipSettings, is 1. I understand this is used when you don’t want to forward ports 10000 - 20000.
Under pbx-settings/rtpSettings, the value for H.264 Video Coding is 99.
On the GXV3370 Codec settings, H.264 Image Size is 720p, profile type is BP & MP & HP and H.264 payload type is 99. Is there anything odd about these settings?
I will set both IPs as local and see if that solves


#13

You are using a VPN, or so you said. Keep-alives and port forwarding should have no bearing.


#14

Okay, so today I was able to fix this.
First I put both network addresses to be “local” to both UCMs under pbx-settings/sipSettings NAT. I’m not sure this one is absolutely necessary since audio calls were working before.
Since Direct IP Calls were working, the solution was on the UCMs. The problem was Codec… I know…you said…but…:no_mouth:
I had to enable the necessary Codec on the SIP trunk itself. By default, new SIP trunks don’t have these codecs enabled.


############### another screenshot below of Codec preference ##################
image
H.264 alone could make video call but no image. So I selected everything and that worked. I know I’ll find out which codecs are not used and disable them.
Cheers guys!!


#15

Glad you figured it out!


#16

Hi,

I am having this same issue. Video doesnt go through peered UCMs. I have tried the same settings as mentioned above by you. “Video Invite failed” is received.

One extension is setup on GSWave. Another extension is SIP enabled IP Camera same as that of GXV3611_IR_HD.

When trying the Video call, it couldnt enable the video.
But while trying with two extensions setup on GS Wave, we can video call.

regards
romush


#17

I did not encounter “video invite failed”, but there are a couple of suggestions on that subject which I would recommend to try out first including “video invite fail!” and https://forums.grandstream.com/t/solved-no-sip-video-call-with-wave-video-app-over-ucm6202-but-gxp3240-works/18080/3


#18

Check video settings in camera.
Also check if you added H.264 to trunks and all extensions.