Video call from Grandstream 3710 and Polycom VVX500 not working


#1

Hi,
I am trying to establish a video call betweeen 3710 and polycom VVX500 but VVX is not displaying the video. I suspect this is due to the video stream size.

I tried setting op different settins in video page as baseline but it is not fixing the issue.

Did anyone experience this issue?

HOw can i force Grandstream to use lower baseline video settings

Regards
Robert


#2

In the trace i can see that Grandstream is sending Video SDP as
fmtp:99 profile-level-id=42801F; packetization-mode=1; level-asymmetry-allowed=1; max-br=256
profile-level-id=42801F

Polycom is responding with SDP as below with profile level id 13.

But Grandstream seems to sending Level 30 and video is not working

Has anyone come across this issue and how to fix this.

Attached is the trace for the affected call.

Regards

Robert


#3

Polycom respond with RCVonly, so it will not sent video.
Try TCP instead of UDP.


#4

Thanks, Marcin.

Polycom responds with recv only because GDS sends Sendonly in the invite. GDS only sends video to polycom and doesnt want to receive any as t hasnt got a screen to display may be.

As a new user I am not able ti attache more screenshots or files. :frowning:

On further investigation and playing around with settings, I managed to force the Video SDP in invite from GDS to the below which is level 2.0. and is negotiated fine with Polycom.

As this is RTP , it will always be in UDP. TCP will only change the Signalling.

Regards

Robert


#5

But when it sends the actual RTP in H264, it decides to send level 3.0


#6

2 way video is not expected as it is a door entry system with no screen. So will be video in one direction " From 3710 to Polycom VVX 500"


#7

Yeah somehow i read it GXV3xx instead of GDS :slight_smile:
Which fw you use in GDS ?

This is more like a bug then something you can set. You try force lvl 2 or 1, but GDS sent lvl 3 which is wrong according to RFC. Make Ticket to GS as on forum we cannot solve bugs.


#8

I am on 1.0.3.35.

Will try the one before and see if it makes a difference.

Just managed to raise a case with the support team.

Thanks again for your contribution


#9

There was 1.0.4.5 but this is temporary removed. Still do not see any fix there.


#10

Please try 1.0.4.9. The 1.0.4.5 removed due to the ECC check bug could brick the device during upgrade, although happened randomly.

GDS3710 is using payload type 99 for H.264, I recall Ploycom is using 97. Please change Plogycom to use same H.264 payload if Ploycom side can be configured.

Unfortunately GDS3710 not able to configure payload type in current firmware.

Hope this helps. Thanks for using GDS3710.


#11

yes, @scadet7 said is correct.

Or, use GS_Wave video version and register it to the UCM, then put hose extensions in the doorbell button configured for calling.

All these required UCM involved. Thanks for using Grandstream products.


#12

@GS_Guy
Thank you. Polycom is indeed using payload 99.
Where can i download 1.0.4.9


#13

Tried the latest firmware 1.0.49 and still seeing the same issue. :frowning:


#14

FYi, I am registering the GDS3710 against our Broadworks R21 platform and the media is staying local and flows between polycom and GDS3710


#15

For the Ploycom phone, could you try configure STUN for NAT and try again? We knew the OPB of BS having issue and video will not come out.

Please advise whether STUN works. Thanks!


#16

@GS_Guy, Hi John, Thanks for the update What is OPB ?.

Not sure why do you think NAT is playing a role in this case as the signalling is working fine and media stays local.

Audio is working fine too and even Video RTP in H264 is being sent from GDS to Polycom (local lan ip to ip) but on the incorrect profile which is what causing the Polycom not to display the video.

If you see the screenshot you would see that GDS is sending H264 in profile 3.0 though it was profile 2.0 in its initial SDP

FOrum is not letting me to upload trace in zip files yet as i am new. :frowning:

Regards
Robert

!


#17

Initial invite SDP screenshot


#18

@robertrozarioa: Thanks for the good catch!

This bug is logged and will be fixed in next firmware.

Thank you very much for using GDS product! Will advise you when firmware is ready. Please keep tuned. Thanks again!


#19

Cool.
Thats good news indeed.
Will be on standby for the new firmware.