Use UCM63xx and wave desktop app register with public ip but it can not hear sound?


Hello everyone.
I use UCM63xx and wave desktop app register with public ip but it can not hear sound
Using a 3rd party application( 3cx, xlite…) the sound is completely normal
What is the problem? Is it due to incompatibility?
Customers they need to register via public ip but they do not use remote connect application.
Has anyone tried it yet?


Dear user,

Thank you for using the UCM63xx and Wave applications! Could you kindly export the logs from the Wave Desktop and send to us for troubleshooting? Btw, what is the firmweare version of your UCM63xx? What is the version of your Wave Desktop? Could you also download the logs from the UCM63xx and send to us for troubleshooting? Thanks for your testing!

Thank you!


Sorry, why don’t you use Remote Connect ?


All versions we use are the latest version.
Here is the log of Wave desktop
Pls check it
Thank you
GSlog ang (473.0 KB)


We have advise customers to use remoteconnect, but they want to use it through such a public ip


the technician must be the technician, the customer must be the customer.
Otherwise you find yourself having to solve problems like what you have,
moreover by opening the NAT you should tell the customer that they are dangerously exposing UCM with related security problems, with REMOTE CONNECT this problem does not exist.


yes, we told them about the security issue, they still want it, so the problem is with wave


Dear user,

Thank you for your feedback and given logs! This seems like a known issue in the UCM63xx and we have fixed this issue in the UCM63xx You can download the internal test version of UCM63xx and try it again.

UCM63xx test version:

Thanks for your testing!

Thank you!


ok we will tell client to update and try again, thank you


Greetings, I would recommend that you use the iax protocol for remote extensions, since you should only open one port for everything, although the recommendation would be to create a vpn and connect those clients through vpn


not a good advice,
IAX is an obsolete project, also IP phones or softphones are not found many,
the audio is definitely not better than SIP, and in case of problems you would be in difficulty, I absolutely do not recommend IAX.


Thanks for your testing! Please feel free to let us know if you have any updates from the client.

Thank you!


Hi @GSSupport74
Customer update problem still occurs no sound
Pls check log UCM and Gslog
ThanksLog UCM and (794.1 KB)


Dear user,

Thanks for your feedback! Since the user does not want to use UCMRC, and we noticed that the user also does not configure STUN/TURN services, so the server responds only the internal network address which is the reason of this issue. We recommended the user to use UCMRC in this case, otherwise, you may ask the user to configure STUN/TURN before using it through public network. Thanks for your testing!

Thank you!


Hi @GSSupport74
After config stun it worked perfectly
Thank you


No problem, Tiennk! Let us know if you have any further questions. Thanks!

Thank you!