USB provisioning


#1

Hi,

I need to provision a lot of Wp820.
I found in the manuals that u can provision with USB.

I tried doing this with a USB-Stick an USB Micro to USB Type-A adapter.
But when i plug the USB-stick in, the device does nothing.

On the USB there is a newer firmware(wp820fw.bin) and the wifi-package(wifiAutoConfig.zip).
In the Zip is only a config file config.xml (config with the WiFi credentials).

What file system does the USB have to be, cant find this anywhere?


#2

Hi,

When you plug in the USB is there any prompt that says USB detected or an icon on top right showing USB symbol? I think the USB is not being detected. Here we have tried Micro USB to USB OTG cables and they work ok. For file format I believe both FAT and NTFS will work. Do make sure those files are on the root directory and not nested in another folder. Please also advise the firmware version on the device.

Thanks


#3

Minimum fw is 1.0.5.5 afair
If you below it will not work.


#4

I dont get a prompt.
I think it will be the micro-usb to usb A that doesnt work.
Im gonna look if i have a other type of connector.
IS OTG needed on the adapter?

System is om 1.0.5.5
Already went to 1.0.7.x to check if it was the firmware


#5

When tested i used micro usb -usb -> USB card reader. Don’t think i used OTG


#6

I have this one: USB-adapter DELOCK


#7

Should work, but USB stick need power that’s why i used card reader.


#8

Hi,

I believe you need to use OTG because it allows the device to provide USB power for the USB drive. We have used below OTG cable with good success here:

https://www.amazon.com/UGREEN-Adapter-Samsung-Controller-Smartphone/dp/B00LN3LQKQ/ref=sr_1_4?keywords=ugreen+otg&qid=1579026917&sr=8-4

Thanks


#9

Maybe i have OTG cable ? no idea just take one from desk :slight_smile: