Unexpected behaviour keep-trunk-cid & keep-original cid


#1

Hi,

Keep-Original-CID
Manual says: Keep CID from the inbound call when dialing out even if option “Keep Trunk CID” is enabled. Please make sure the peer PBX at the other end supports matching user entry using the “username” field from the authentication line.

Somehow this isn’t happening. When I enable Keep trunk cid every outbound call actually gets the trunk cid. Maybe I do something wrong.

If i set our main cid in the From user field and check keep trunk cid, he does keep that cid in any condition, even when an inbound call is forwarded to a cell-phone for example which is not what we want. We want to see the cid of the actual caller, not the cid of the pbx trunk.

If I leave the from user field empty and settings as above, I get “unknown” sending out as caller id.

If I leave the from user field emty and I uncheck Keep-trunk-cid, forwarded calls are showing the correct cid, the one of the original caller.

But this also implies that I need to set the company CID on every extension so when they dial out the correct outbound cid is given. This results of course that also internal calls results in sending the company cid for everybody and we can’t identify who’s calling.

All help is greatly appreciated,

Thx
Yves


#2

There are two side to this - what the PBX will do and what the provider will do or allow. I assume you wish to be able to see the company CID when extensions make outbound calls and conversely you would like to see the original CID in the event of an inbound call that is forwarded out.

Leave the keep trunk CID blank/unchecked and check the keep original CID.

Then go to SIP Trunk and use the DOD settings to create the number you wish and assign the needed extensions to same. When one of the assigned extensions makes an outbound call, it will use the number you established as the CID.


#3

Hi,

Ok, that did it. I already played with those settings but forgot to remove the company cid in the extension’s config I noticed now. Works as expected, except for the thing that forwarded calls have a slightly wrong cid. Outbound route is set to strip 1 and prepend 32, but still the nr comes out like +0489xxxxxx while it should be +32489xxxxxx.

Thx


#4

The route and CID can be independent of one another. The question is whether or not the +04 number was the seen CID upon the inbound call at the UCM? You wanted to keep the “original”.


#5

ok, sounds logic. it comes in in format 04xxxxx. I just tested with another trunk (same settings) and there the cid is send out correctly, lol.

Anyway, I just noticed it still ain’t fully correct, despite what i’ve wrotte above. I just noticed forwards are ok (CID) BUT calling out with no cid on the extension results in private nr as cid when i leave From user empty (logic, where would he get the cid)

If I put our company cid again in the from user field, forwards fail again cid wise (sending company cid again)

Keep trunk cid is unchecked in both scenarios

With DOD settings, you meant enabling DOD as From name in the advanced settings of the trunk, right? I don’t see any other settings concerning DOD as far as i know?

EDIT: FOUND what you meant, Trying out.
EDIT2: ok, this works, but i can only assign the company nr 1 time as DOD. I want everyone to dial out with the same cid, the main company nr.

Many thx


#6

So add all extensions to the DOD setting.


#7

Lol, indeed. Sometimes solutions are to easy to see for me obviously :slight_smile: Thank you so much, all fixed now.