Under 11 digit dialing adds + to the dial plan


#1

I am hoping someone can help me out with this issue.
I have a GXP2160, and on one of the accounts if I dial out with less than 11 digital dialing it adds a + to the number (+5551212, +8005551212, but 18005551212 is ok). It doesn’t happen on the other accounts. I have looked and compared it to the other account’s setup, and for the life of me I can’t figure out the issue. When it does this, it still dials out from that account, but if I hit redial I get a busy signal because of the +.
The dial plans on all accounts are the same.

(Firmware version: 1.0.9.118)


#2

Look in the phone and for the account of interest and then check the dial plan.


#3

I have never seen my own calls add a + sign after dialing, but I have seen the plus sign on incoming calls that don’t let me call back out with redial

2 things to do
add a duplicate outbound route to accommodate any plus signs
for example:
_+1xxxxxxxxxx
then strip the first digit before sending

next set the setting on the phone to (with Pcode for zero config):
Bypass Dial Plan Through Call History and Directories. 0 - No, 1 - Yes
P6758 = 1

This way when the phone sees the + sign it’ll ignore it and just send the call anyway then the UCM strips it off and sends the call.


#4

Thanks Ipneblett, but all dial plans on the phone are the same. Just this 1 account does this.
Also, I believe this started after a firmware update.


#5

Thanks Istutesman, I tried what you recommended, but it still adds the “+”.
I believe this all started after a firmware update
Current Firmware: (1.0.9.118)
There is another firmware update, I’ll give it a try.


#6

Right, my solution won’t stop the + sign, it just teaches the system to ignore it.


#7

Sorry, I did a test, and the phone doesn’t ignore the “+”. It still gets a busy signal on redialing.


#8

can I see the outbound route and the CDR log?


#9

The log on the phone shows the + with the phone number.
The phone is not going thru a PBX, it’s setup as a softphone direct to the SIP provider.
I looked at the SIP providers log, and the call never gets that far.

I also tried swapping the account (3) to another account (1), and putting the SIP password on the swapped account, for some reason I am unable to hear anyone on the other end…


#10

Ahh, that is not the phone you described initially. You would have to add the + sign to the dial plan for it to send it on a softphone. Then the SIP provider would have to accept it from there.

Same fixes, just different places.


#11

Sorry for the assumption that it was on a PBX…
This is the current dial plan on the phone:
{ *123 | *400 | [2-9]xxxxxxxxx | 1[2-9]xx[2-9]xxxxxx | [2-9]xxxxxx | [49]11 | 0 | 00 | *x. }
Which is the same dial plan on another account, but that account doesn’t add the “+”. It’s weird.


#12

I was referring to a GXP21xx as apposed to a soft phone.

I would open a ticket as this is odd behavior if the outbound calls are adding it.


#13

Thanks I will…
Just to explain, the 2160 is setup using the softphone settings provided by the SIP Provider, and is not setup as a SIP phone to a PBX then to a SIP Provider. Sorry again…


#14

It can be that incoming calls Provider mark with +, then when you call back you can choose call from Live DialPad instead of normal.


#15

Thanks, But outbound calls also… I even removed the provider setting, and the phone itself it adding the “+”.
I have created a support ticket. Thank you everyone…


#16

Just a minor update:
Seems to be an issue with F/W 1.0.9.xxx.
F/W 1.0.8.56 doesn’t have the issue.

GS Engineers are working on it.