Unable to update FW on newly purchased GXP1625


#1

Unable to upgrade firmware on GXP1625.

In the phone’s web UI it reports version 1.0.4.82.

In the “Firmware Upgrade and Provisioning” section there is no option to manually upgrade the FW and it is not updating automatically.

How can I get this thing up to 1.0.4.128?

Thanks.


#2

I can’t say for sure as I haven’t used that exact phone. However, change the firmware path to firmware.grandstream.com and ensure the phone is set to http.

Click save and apply then try again.


#3

Thanks for the input but no luck. I also set/reset “Firmware Upgrade Notification” to no.

I’m guessing that the .1.0.4.82 version is to far out of date to update automatically. Unfortunately, this phones web ui, unlike my 2170s, is not offering the ability to manually upload a file so that that I could sequentially bring it up to date.


#4

The firmware currently installed is not quite a year old and I did not see any limitation that precludes this version from being able to take the new one using its normal settings.

The path that costwise provided is correct and the protocol type should be HTTP. You should also check the settings for Always check for firmware and then once set, reboot the phone.

I am assuming that the phone has not been provisioned and that the firmware location as was provided remains intact. If not, then do a factory reset, remove the provisioning file from whatever device may have it and then start anew.

The phone should restart whereupon it will boot up completely, obtain an IP and then show the default screen. A short while later it will check behind the scenes to see if a new version exists and if so, it may present a message about a new firmware being found, update? Y/N? (it may not be on this model, but it on the higher end). In any event, if the message is present, answer Yes. If not the phone will simply start its update sequence which will present a blank screen with only the status of how the update is progressing and will complete and reboot back to the home screen when complete.

If this fails, then you may need to try and download the firmware and set it up on a TFTP server and point the phone to same using TFTP for the update method.


#5

Thanks!

Now resolved.


#6

Hello!

How did you do it? I’m still trying and nothing! Mine is a GXP1628 with 1.0.4.82. I can’t make it upgrade to 1.0.4.128. I even tried to upgrade to 1.0.4.106.

I have 30 others GXP1628 that came with 1.0.4.106 that I could upgrade easy to 1.0.4.128.

It shows Firmware Update and nothing happens. I tried HTTP, TFTP, etc. It starts and never finishes.

After a while, goes back to the normal screen, not updated.

Thank you


#7

I had trouble with a 1625 a while back, over a year maybe two.

I had to factory reset the phone while connected to a network without a UCM. Then update the firmware path and make sure it was set to check for new firmware after reboot. Save and apply. Then reboot and go get coffee.

I never got to the bottom of the problem but I assume there was something overriding DHCP options or something.

I’ve had to update this phone since then and it worked without issue.

Good luck.


#8

Turn off DHCP option 43/66 in phone.
Then try again.


#9

Hi Camilo,

It’s already been long enough that I can’t recall exactly what I did. My initial problem report was accurate. Somewhere in my attempts I think I got to the browser interface for the phone and was able to force the update there. I know that I did not to anything like download it to a local TFTP server.

I guess do what I did and keep beating on it until you land on the correct sequence of steps. I wish I could be more helpful.


#10

Thank you for your reply!

yes. it worked! all of sudden!!

Thank you!!!