Unable to send DTMF to IVR when a second call rings my GXP2170


#1

When I am on a call to an IVR i am able to dial DTMF digits without issue. As soon as another call rings to my phone on a secondary key I can no longer send DTMF until the call stops ringing. I have tried Yealink and other phones and do not have this issue. It only seems to happen on the GXP21XX which I have over 400 installed. Is there a setting I can change to correct this or is there a way to ignore the second call when I am on a call?


#2

Firmware version?

Normally when a second call comes in, there is a indication at the bottom of the screen to accept or reject. However, this may be subject to the firmware and how the line keys are used.


#3

I am on 1.0.9.132. I do get the notification. The issue is while the call is ringing my phone, even though I am on the call to the IVR, I can not send a DTMF tone to the IVR. It is as if my keypad is interrupted until the call is answered or stops ringing on my phone. I do not see why an incoming call should have any effect on my existing call. Surely there isa setting for this.


#4

Well, you also asked about a way to ignore which was the quick answer. As far as the other, I would need to test as I can’t ever recall having had this scenario. Even if I did, I think my natural reaction would have been to see who was calling and then either accept or reject the call as I don’t let the second call keep nagging me.

Maybe others will know as it will be a while before I can test.


#5

Thanks!!! By ignore, I meant the phone would ignore, not the user. Hitting the Reject key works as long as it is a call to a Queue or Ring Group. If it is a Private DID or call to their extension it goes to Voicemail when you reject it. I still believe there is a setting for this as I have tested this with other manufactures phones and it is not an issue. The incoming call should not interrupt the keypad while it is ringing.


#6

Yes, the reject is essentially sending a 486 busy back which then causes the PBX to follow whatever rule is set for that condition. If it is VM, then yes, it goes there. The same 486 is sent for a ring group or Q, but because it is a system owned call, the extension rules are ignored and the rules for the ring group or Q are followed according to the ring strategy and settings for same. So, it is not a question of the phone sending a reject, but rather what the PBX does with the call once the extension owner has rejected it be it a Q, ring group, direct or other.

While I share you opinion that perhaps it should not interfere, just because other makes of phones don’t interfere, does not mean that all (including GS) follow the same logic. If you want to ignore the call, then you disable call waiting and preferably at the PBX side for the extension. The PBX upon seeing the extension is busy will not attempt to send the call to the extension, but will instead follow the busy rules for the extension. If you do not disable at the PBX but only at the phone, the PBX will send the call which may cause the phone to chirp (start to ring) before the phone responds with the 486 busy.

Nevertheless, I’ll get to testing this today. I briefly looked at the settings, but saw nothing to indicate some setting that might alter the behavior. However, my search was really a glance and not definitive.


#7

Thanks Again for the response. I will disable the Call Waiting for now. I should have thought of that. Please let me know if you get the same result from your test when you have time.


#8

I tested and confirm your findings.

It appears to me that when a second call arrives while another call is in progress, the focus of the phone shifts to the second call (display and keyboard lock) which then awaits your disposition of same (answer/reject).

While I personally do not find this to be as objectionable as you, as I have always provided the response, you would need to submit a feature request.

Sorry for the delay.


#9

Thank You for your help in this matter. I will submit a feature request.