Unable To Backup Via SFTP - "Wrong Account or Password!" Error


#1

I am unable get any of the UCM systems we manage to log in to our SFTP server to backup. I always get the same error “Wrong account or password!”, however I know this isn’t these aren’t the wrong credentials.

I am able to log in via SFTP through other clients using the same credentials created for the UCM systems. I have tried this on a few different systems at different firmware levels and none of them seem to work. I have tried using simple user names and passwords with no special characters and get the same result. The only thing to note I suppose would be I’m not using the default SFTP port, but that shouldn’t be an issue. I don’t have this issue on any other Asterisk or Asterisk derived systems - Switchvox, PhoneSuite, FreePBX, etc.


#2

I ran into a problem with LastPass changing the UID and password and me not noticing.

If you’re using a password utility, try disabling first then try again.


#3

I wish it was something this simple haha!

I did disable LastPass just to be sure, but same results.


#4

Firmware ?

[2019-02-13 22:00:01] Schedule Backup backup_000B82587406_2019Feb13_13365.tar Succeeded!

Also do you use Destination Directory ?


#5

I have tried on a few levels of firmware - 1.0.8.13, 1.0.17.16 and 1.0.15.14 with different users.

And yes, I use destination directories. Each user has their own directory. I am able to log in with each use to their respective directories, just not from the UCM. I do see traffic coming through on the port I’m using for SFTP on packet captures from the UCM as well as the SFTP server, just no connection and the same error.


#6

destination you do not start with \ just name


#7

Yes, I am aware. I’m not beginning with /

I’m getting an error for invalid credentials when I am putting in valid credentials.


#8

You added permission to create directories ?


#9

Yes, the user has Read/Write on the directory. I log in with each user and create/delete a directory to verify.


#10

Maybe this not default port is issue ? (Bug in UCM).


#11

Did you get this figured out? I’m running into the same issue.