UCM6301 with Wave issues


Having an issue with recieiving calls on my Wave windows app.

i am currently using the App on the same network as the UCM6302 can make outbound calls but can recieve calls. inbound or from another extension on the network.

I a able to use an extension external to my network as and it recieves inbound and internal calls,
Have disabled antivirus and firewalls. tested on older versions of windows 10 and even on windows 11.

Only error i get is the app will pop up and say missed call the second the phone should ring.


Dear user,

Thank you for using UCM63xx and Wave application! I am trying to get more detailed information about your test. May I ask what is the Wave Desktop app version? What is the UCM63xx firmware version you are using? Could you kindly export the logs from your UCM63xx and Wave application in this case (Please ensure that the exported logs are in the same test case)? Thanks for your testing!

Thank you!


my wav app versions is 1.9.12 and my UCM versions is
i am still a new user so it wont let me upload anything.
Im guesing its the Media line error
[8421][2021-10-15@14:46:48.141] sipWebRTC:INFO: receive sip request.
[8422][2021-10-15@14:46:48.141] sipWebRTC:INFO: INVITE message of lineId (-1)
[8423][2021-10-15@14:46:48.142] sipWebRTC:INFO: get channelID: PJSIP/1001-0000037f
[8424][2021-10-15@14:46:48.143] sipWebRTC:WARN: main direction is not found!
[8425][2021-10-15@14:46:48.143] sipWebRTC:INFO: sip header callType vaule: undefined
[8426][2021-10-15@14:46:48.143] sipWebRTC:INFO: get callType (p2pAudioCall)
[8427][2021-10-15@14:46:48.144] sipWebRTC:INFO: get remote capabilities: {“haveAudio”:true,“haveVideo”:false,“audioCodecs”:[“PCMU”,“PCMA”,“G722”,“G729”]}
[8428][2021-10-15@14:46:48.144] sipWebRTC:WARN: Media lines does not meet the requirements, call hang up automatically…
[8429][2021-10-15@14:46:48.172] wave:INFO: request action: getMultimediaConferenceExten
[8430][2021-10-15@14:46:48.175] sipWebRTC:INFO: Send:
SIP/2.0 100 Trying
Via: SIP/2.0/WS;rport;branch=z9hG4bKPjc7e2639f-404b-49b9-b613-0f683db604d0;alias
From: “Hayd” sip:1003@UCM6301;tag=35211629-201a-40e8-97c3-99d1d33ba640
To: sips:1001@
Call-ID: 6873ee90-7c99-4650-82ff-e4c638653977
CSeq: 7448 INVITE
Supported: replaces, path
User-Agent: Grandstream Wave Desktop 1.9.12 (chrome 85.0.4183.121 windows)
Content-Length: 0


Dear user,

Thank you for your testing and feedback! We will evaluate and analyze this issue based on your given logs. Could you kindly help to capture and send the full logs to us? You should be able to upload the full logs or put the full logs in the txt file and send to us for troubleshooting. Thanks a lot for your testing!

Thank you!


sorry for the delayed response.
attached is the wave app logs. i had to zip the Tar file for syslog as it was to large.
GSLog- 10_22.zip (2.0 MB)
syslog (1).zip (3.9 MB)


Dear user,

Thank you for your feedback! We checked your given logs and we suspected that this issue may be generated from the UCM server side. Could you kindly enable PJSIP logs and recapture the logs from the UCM side, and send to us for troubleshooting? You can follow the screenshot below to configure the captured logs in UCM Web UI. Btw, this issue can be reproduced 100% or randomly reproduced? Thanks for your testing!

Thank you!


it can be reproduced everytime a call comes to my extension. happens both if its internal or an external call coming in.
ill make those changes and get the logs from some testing this morning.


Dear user,

Thanks for your feedback! If this issue was reproduced 100%, this issue may be generated in the UCM side. Please offer the UCM syslog to us for troubleshooting. Thanks for your testing!

Thank you!


Attached is the logs from today. last two calls to my extension 1001 both instantly marked as missed call on the Wave app.

syslog (2).zip (4.3 MB)
GSLog- 14_39.zip (2.5 MB)


just to take a test, try disabling “Strict RTP” in RTP Settings and then restart UCM


Dear users,

Thank you for all your feedback! This issue should be caused since the extension had not configured video codec. You can try to configure the video codec for the extension following the screenshot below in the UCM Web UI and try again. Thanks for your testing!

Thank you!


The last solution worked for me in my case. I only had PCMU for the Extension. Thanks for your help


that worked perfectly. thank you for this.
What are the recommended codec for internal connections between UCM, handsets and Wave apps?


Dear user,

Thank you for all your feedback and the good news! This is depending on the user’s requirements. You can configure it as the screenshot shown above. Let me know if you have any questions.

Thank you!