UCM6202 - Ringing but no audio in external


#1

Hello,

I can’t configure my IPBX to run outside LAN.
When i’m not in the lan and i make a call the sip exchange works fine but my computer send audio to private adresse of UCM…
I looked in the SIP packet and for i think that the UCM send his private IP instead of Domain Name or public IP…
I entered the Domain name in all the field that requires it…

Can you help me to configure that ?

Best regards,
Simon


#2

Look at the flow of a call in your trace and then open up the INVITE. Open up the headers within the INVITE and look at the contact and connect headers. The IPs within will show what the device that sent the INVITE is telling the other device to use in its messaging to setup the call.

Look at the 200OK for the same call and open up as above and again look for the contact and connect headers as this is the other device telling the other device to use when communicating back,

What you are showing is not related to a call per se, it is a Notify message. The line just above it is the 200OK and the INVITE is above the 180 Ringing message.


#3

Thanks for your answer.
As you can see below the field “from” is good but the field contact told private ip of ucm…


#4

Don’t care about the from field, that field is typically used to show who is calling (Caller ID)

Care about the CONTACT which is showing a private IP.

In the PBX settings, SIP settings, NAT

  1. In external host input your FQDN (resolves to public IP) or your public IP
  2. In the SDP box below external host, enable (check) it.
  3. In the section below for local network, please enter your local lan info.
  4. In the UCM extension settings, enable NAT for the extension that will be remote.
  5. DO a backup of the system
  6. Upgrade to the latest 9.127 release for the UCM
  7. Insure that any SIP ALG is disabled in the router.

The above only addresses the UCM side, there is more to do with the remote.


#5

All your point were done except the upgrade.
I’m running 1.0.18.2.
I will do this backup and upgrade then keep you inform.
Thank you again


#6

Hello,

I did the upgrade, and still the same issue…
For information we changed the UDP port 5060 to 5070
I don’t understand why my IPBX send his private IP to establishe the voice communication

Capture4


#7

Make a call and PM me with the pcap or a location where I can retrieve it and I will advise.


#8

Hello,
I can’t PM you so i put that here…
Below you have the link to download the pcap.

Start of the SIP traffic : TIME = 9.88
172.20.10.2 is the private IP of my computer where is the softphone
1001 is my extension
192.168.66.90 is the private IP of the UCM6202
77.132.40.115 is the public IP of the UCM6202 also know as ucm.lutessa.synology.me

Thank you for your help,
Best regards


#9

Send a screen shot of the entire page for PBX Settings, SIP Settings, NAT. Is there a reason as to why the UCM and PC are on different LAN segments and what mode is the UCM running - DUAL or Route?


#10

Below you’ll find the settings.
When they are in the same network there is no issue…
It’s only when we are trying to make a call from outside.
We are running in switch mode


#11

Is there a VPN between your computer location and the UCM location?


#12

No my computer is on another connection.
With VPN i don’t have this issue that’s work well


#13

Ok, just checking and there will be more.
The fist issue is that X-lite is telling the UCM to use the local address of the computer by which to communicate both SIP messaging and RTP (voice). This is the Invite from X-lite (which is the first message sent in the call) -

X-Lite is being discontinued in favor of Bria and my copy of X-Lite has expired, so I am not much help in directing you to the NAT settings in the app to get it to send the public IP of you computer location.


#14

Additionally, when you get into the UCM and go to network troubleshooting and ping the FQDN, what IP does it resolve to?


#15

The private IP


#16

For me it’s normal that my private IP appears on this capture because i capture it on my computer.

I’ll try to setup bria with free access.


#17

And there are both answers. You have the FQDN also set somewhere on a local DNS server:

You told the UCM to use the FQDN for the external host, so when it sent the message to your computer it resolved the FQDN to the IP on your DNS server and inserted that local IP into the contact and connect headers which it sent to your computer which in-turn told your computer the IP and port to send back-

Once your computer received the 200OK, this is where the call became somewhat official and your computer started sending to the 192.168 address as it was instructed to. The UCM never saw the ACK as it was sent to the wrong IP and thinking that your computer missed the 200OK, it sent another 200OK which has the same local IP because of the FQDN, so it became a wash, rinse and repeat at which point after about 32 seconds of this, the UCM would assume the connection to your computer had failed and it would terminate the call.


#18

I’ll try to change external host setting and set my public IP instead of FQDN.


#19

You will still need to fix x-lite as well.


#20

That’s work with this parameters, no issue with xlite.

Thank you for your help.