UCM6202 - GPX2130 on NAT with One-way Audio


#41

Also I’ll post some of the settings I had to setup on the NAT Phones in order to work properly in my case, so if anyone has similar issues can test their networks with these settings:

  • Use of STUN is mandatory. Go to Settings > General Settings and input there a STUN server. Here is a list of them
  • On Account > SIP Settings > Custom SIP Headers, option “Use X-Grandstream-PBX Header”, set it to NO.
  • On Account > Network Settings > NAT Traversal, set it to STUN, and on Proxy-Require, input the extension number. Also if you want, set DNS Mode to “Use Configured IP” and setup the fields with your preferred DNS servers.
  • On Account > SIP Settings > Basic Settings, set Register expiration and Subscribe expiration to 10, and set “Enable OPTIONS Keep Alive” to YES.
  • Setup different SIP ports and RTP Ports for each phone.
  • On your router, opening those ports, help, if you don’t want the fuss of it, you can check UPnP and check if the combination of that works fine with STUN, if not, you need to open those ports.

Hope this helps


#42

The settings above are not a “solves all” setup for remote endpoints.

STUN may not be needed If the IPs at both ends are known and both are static, You can input the public IP of the remote site into the phones NAT IP setting and use keep-alive.

If you have control of the remote router and can assign a static/reserved IP to the remote phone and can do port forwarding to same even better. For multiple phones behind the same NAT router,. each should have their own local SIP and RTP port so that each phone is unique.

The proxy require is also not an applicable setting and not with the extension number.


#43

Correction of above. Tested the settings again on the phones and Proxy-require field is not needed, however, STUN is needed, and if the X-Grandstream-PBX header option is active, when phones make a call, they drop and no RTP, ACK or Rigning is transmitted, when this option is off, phones work correctly.


#44

As stated “may not be needed”. Did you have the remote public IP in the NAT IP in the phone?


#45

On NAT IP on the remote phones I have the IP of my remote office, is that correct? Or should I use the WAN IP of my UCM?


#46

Use the public IP of the location of where the 2130 is.

Just as the UCM is set in the SIP settings, NAT with its external host or public IP, the same is true for the remote site. This setting tells the UCM what IP to use when responding back to the phone, just as the UCM is telling the phone what IP the phone should use when responding to the UCM. Fundamentally, each device is telling the other what the public IPs and as you have port forwarding, the messages will hit the router at each site and be routed accordingly to the internal device.


#47

True, phones work just fine without STUN server, using port forward and setting up NAT IP on each remote phone.

Thanks a lot!