UCM6202 - GPX2130 on NAT with One-way Audio


#1

Hi everyone!

here is my arch:

phones <> UCM (switch mode) <> router (MicroTik) <> INTERNET <> router <> phones

On my UCM side:
Outside extensions have NAT activated.
On SIP > NAT settings; SDP is activated, and external host has my Static WAN IP.
SIP port is 51064 it’s opened on router
RTP ports are 10000 to 2000, also opened on router

On my external site:
They have Static WAN IP.
Phones register to SIP just ok.
Inbound calls and outbound calls, work
Everytime they only get incoming audio, they never send out audio.
RTP and SIP ports are opened on router.

Packet capture on phone, shows that the phone recieves UDP-RTP Packets from UCM WAN IP, but they do not send any UDP or RTP packets to router or UCM WAN IP. They only recieve SIP Packets. The same with a packet capture form the UCM, I can see how the UCM sends out RTP packets and send and recieves SIP/SDP packets, but no RTP packets comes from the WAN IP of my external phones.

Phones are setup like:
SIP Server: UCM WAN IP + Port
UserID/AuthID
On Accounts > SIP Settings > Custom SIP Headers: Use X-Grandstream-PBX Header is off, Use P-Access-Network-Info Header is off, Use P-Emergency-Info Header is off… if they’re active, calls or register don’t work.
On Settings > General Settings > Use NAT IP: is set to the external WAN IP (it’s static).

Does anyone have a bit of insight here? I’ve been like this for a month, and have no clue.


#2

MikroTik - SIP ALG disabled?
In the extension settings of the UCM, enable NAT and disable can direct audio.


#3

Sorry my bad, forgot to mention. SIP ALG is disabled on both ends, and extensions have disabled ‘can direct media’ and NAT it’s active only on the extensions that are not in the UCM subnet.

Should I activate NAT for every extension?


#4

NO. no need. If you like, take a pcap and pm me with same.


#5

What are the firmware versions on the UCM and on the phones?


#6

UCM:
Base - 1.0.18.12
Boot/Core - 1.0.18.2

Phones:
Boot - 1.0.7.2
Core - 1.0.9.92
Base - 1.0.9.101


#7

Thing I forgot to mention. When there’s a call from my remote site, calls always ends after 32 seconds, precise 32 secs. I think it’s due to inactivity since UCM does not register any RTP, but I can see that still during a call, UCM sends SIP/SDP packets and the phone gets them. But no ACK for the call.

Phones on the side of the UCM doesn’t have that problem, calls can last 3 min or more.

Also, when I call from an external number or I do a call (from the NAT phones) if I set a call to be on hold, or if I hang up or somebody ends the call… the call still continues on the phone that hasn’t hang up.


#8

In account X–>network settings
Try setting the nat traversal to Keep-alive on the phone.


#9

Been there, done that… same results. Call ends after 32 secs and only incoming audio. I’ve tested STUN before, but I’ll give it another try.


#10

That’s definitely an RTP timeout that is timing out


#11

Though it may not be the timeouts issue as much as the path of the RTP stream.


#12

Also I’d update the phones firmware off of that version.


#13

Timeouts on the phone are set as default. Also tried to activate RTP keep-alive config on ToS on the UCM, but with no success :frowning:

Any other way or other RTP timeouts I should be aware?


#14

Oh! Is it buggy? Which firmware should I use?


#15

I didn’t like any of the versions between 1.0.9.69 and 1.0.9.108


#16

So 1.0.9.69 it’s ok? or should I aim for 1.0.9.63?


#17

69, not 63


#18

32 seconds is not a RTP issue, but a T1 timer issue. It is indeed a NAT issue. The call is being set-up and RTP may flow, but the final response is not being seen and the timer fires and ends the call. That is also why some calls do not disconnect…they do not see the BYE.


#19

Ok, so it’s not RTP it’s about the call not been fully established, hence NAT. So what should I do? I think I’ve tried everything, port forward, not forward anything, UPnP, no UPnP, STUN, Keep-Alive… I’m running out of ideas


#20

I downgraded to .69, still the same happens, it’s definitely a NAT thing… but I don’t know if it’s my UCM network or my outside network, since UCM net sends audio and packets I’m guessing it’s my outside net?