UCM Ext. Follow Me not working


#1

UCM6202 FW .20.17,
Only 1 phone for testing, GXV3240, which has multiple extensions registered.
VoIP trunks and in/out rules working

I enabled Follow-Me for one extension account for an external # (added, saved, applied), Skip trunk auth checked.
I see no indication of an outbound call attempt after the time period (10s). I CAN call the same external # manually from the extension on the GXV.

ALSO
Simul-ring on the extension to the same external # does work if Follow-Me is not enabled. If FM is enabled, neither work.

Anyone have any ideas why FM doesn’t work?
Thanks


#2

so there are some errors in the trunk settings.


#3

Are you thinking of anything specific? Inbound & Outbound calls both work on their own.


#4

nothing in particular, but sometimes it had happened to me too, it was the trunk with a wrong setting, it’s just an idea


#5

It could also be that the phone system doesn’t have permission to make the call. I have had this issue . . . and maybe I solved it the wrong way. My solution involved setting up a new outbound route and prefixed a “9” on the dial plan. Then I prefixed a “9” when putting in the follow-me number, and it worked. Once it works I quit wondering why, as a general rule. :slight_smile:


#6

Set dod correctly and mark this:
image

Problem is that follow will try use original CID which is denied by server normally.


#7

Most of my clients want to see the original caller ID on the “Follow Me” device, usually a cell phone. Wouldn’t checking that box mask the original caller ID?


#8

Yes, but provider should not allow this anyway. It insane if any provider allow.
I can call from 112 (or any other emergency number) to you, what you will think ?
Or maybe from your own number (masked via DOD) on my outband.

Can you see problem ? :slight_smile:

So normally provider denied calls that are not from your numbers.


#9

Marcin, in the NA region, many providers will allow a CID to be non-owned. I can change any of my outbound CIDs to anything I want and I am guessing that while I know of some providers that won’t allow non-owned numbers to be sent out, most do.

This is the problem we have in the US with Robocalls coming from spoofed numbers. They will call and if a call-back is attempted, chances are good that the number is fake ( an area code with an exchange and/or number that is not used in that area code.

However, the point is valid as some US providers will not pass a number not associated to the account.


#10

The whole issue of being able to display what you want (need?) is a double edged sword:

  • if allowed, the customer can get what he wants; an example of which we are discussing above

  • if allowed, it can be (and is) misussed; the law of unintended consequences

As an tech, I like having this ability as it allows legitimate business needs to be met. As a SPAM call receiver I do not like it as it allows these guys to get away with too much.

Oh well…


#11

Thank you for all the ideas so far.
The topic about cid origin is worthy of discussion in great detail. However for this particular problem it’s important to note that the simul-ring feature on this extension to the same external # does work and it passes the original cid. Therefore cid origin is not a likely issue for this carrier.


#12

Where are you looking to see the outbound call after 10 seconds?


#13

I believe that simultaneous ring is a completely different thing that FMFM.

In the first case, the UCM is merely passing a live inbound call to two different devices on the system.

In the latter case, the UCM is answering the live inbound call, and then forwarding it to a specified device. In this case it is initiating a new outbound call.


#14

I looked for evidence of an outbound call attempt in Active Calls, CDR, even a UCM capture.

Does Simul-ring to an external # (cell phone) at the extension level not require the UCM to make an outbound call?


#15

IN your outbound route, is filter on source callerID enabled?


#16

If no tarce of invite from UCM, then outband route do not allow calls.

Create outband with Internal privilege level and pattern as your number you forward.
Test again :slight_smile:


#17

“is filter on source callerID enabled?” No
Outbound rule has Internal privilege, and no pattern restrictions.


#18

for similar reasons I’m going crazy on a similar problem, I’ve solved it by enabling “Keep Trunk CID” on the trunk, if you want you can try.


#19

UCM sent this packets or not ?
There is no point fighting if we do not know this.