UCM Dual Mode - how to enforce particular SIP IP in Zero Config?



We have a UCM 6510 configured in dual network mode - LAN1 is connected to external network (with public IP on it), and LAN2 is connected to LAN. External network (LAN1) is only used for some sip trunking, and LAN2 is the default interface.

The phones (they are in LAN, obviously) are configured via Zero Config. However, PBX sends its “LAN1” IP (public address, unreachable for the phones) as a “sip server” address, instead of the LAN2 IP.

In dual mode (when the PBX has two IP addresses), is there a way to force, which “SIP Server” IP to send to the phones in zero config? Because by default PBX is sending a wrong one.

The only fix we found so far is to manually set the right IP in the “SIP Server” custom field for each phone, but unfortunately this field is not configurable globally and we have to set it per each phone.

Thank you!


Set it to route mode - eth1 to the Modem Gateway, eth2 to the LAN where the telephones are.


We need it to be in a Dual mode. All phones communication, internal trunks and other traffic is going through the internal network (LAN2), and the LAN1 (public network connected interface) is only used for some external sip trunks (with certain manual static routes).

So the question is, when the PBX has 2 IP addresses, how to set the right one for Zero Config? By default, for some reason, the phones receive IP from LAN1 as a “SIP Server”, instead of the LAN2 (internal) IP, even though they are in the same network as LAN2 interface.


on zero config you can set many values, including the required one.
The fact remains that (in my personal way of thinking) the dual is not the best way to manage UCM, except for special cases.


That’s right, there are many values in Zero Config, and I can set the “SIP Server” field, but per_phone, which is a lot of work. I’m asking for a way to set it globally.
I’m thinking of setting Option P47, it can be configured per model template. Haven’t tried yet though.


What is handing out the IP addresses ?


Both interfaces on the PBX are configured with static IP addresses.


What is the DHCP server


The DHCP server (for phones) is a Windows server.


All telephones have “Allow DHCP Option 43 and Option 66 to Override Server”

Check your phones - this item is under Maintenance --> Upgrade and Provisioning

If this is set to “on” turn it off on one phone and see if you can then zero config it.


Did you managed to solve this?
I’m facing the same problem, P47 sets the right SIP serve, but in Notify packets the UCM inserts WAN IP (but should be LAN).


Me too have this problem.
8 month and GS cant resolve…


You can only deploy with Zero Config on Lan 2 in software else the config file will not populate to the handset.


It is bug in DUAL i think.
It sent data for 2 LAN.

You can fix it half manual:

  1. Set config link with correct IP (in phone)
  2. Set Account manually for each phone (correct IP again in exact phone template).

It is pain to do, but it work.