UCM 6510 PRI issue


#1

We have started having an odd issue with our UCM 6510 PRI trunk.

We have some numbers that go to an IVR and some numbers that go to Ring Groups. Starting today I believe, anyone calling in on one of the direct to ring group numbers will get get a message “Your call could not be completed…” or a busy signal if the call is not picked up in first five seconds. If the call is answered within the first five seconds there is no issue at all. If the call goes through the IVR and then to that same ring group, there is no issue at all either.

I contacted our carrier and they indicated that they believe it is something in the PBX (though I am quite sure the call not completed message is generated by their equipment).

I can take the inbound route for the direct number and change it from Ring Group to extension, and everything works fine as well. It is only if it directs to ring group that we have the issue.

I tried updating to the 17.16 firmware to see if that had any impact and it did not.

Another oddity, though this has always happened, if someone dials into a ring group, they do no hear rings on the caller side. The phones in the ring group ring, but nothing for the caller. I have tried turning on ring back, turning on hold tones, etc and they hear nothing. If I set that same inbound route to an extension, it rings fine for the caller.

I have tried everything I can think of to try, so any help would be appreciated. Right now I have just directed everything to run through the IVR, but this is not the best option for us.


#2

@rhein, I have absolutely no experience with PRI. However, I do know that when a call comes in and it is answered by an IVR, the carries sees that the call is answered. When a call comes in and it is answered by a Ring Group, the carrier does not see the call as being answered until such time as someone actually answers the call.

In a SIP situation, the work around I have used is to have the call going to a Ring Group answered bu a dummy IVR that just puts the call into the Ring Group. Carrier happy and client gets what they want.

Otherwise, go back to the carrier and ask them what the time-out is on their system for a call to ring before they consider it “not completed”. Then try to get them to change that to a value that works for you.


#3

I have been suspecting that what happened is they changed the timeout. Tested dummy IVR and that works for a workaround.

Thank you!


#4

IVR pickup call while ring group not.
That is biggest difference.

Also UCM can try sent 183 ring to carrier and receive some bad response.
Also it can be ring group set wrong and it not have destination which end with disconnect.

Anyway you have tools to catch signal on E1/T1 then you can start analyse what is going there. SS7 is little similar to sip so you can guess general what is wrong there.


#5

You need to check the PRI for Errors. If you have slipped frames or timing issues you will have all kinds of issues on the PBX like what you are describing. Timing is everyting on PRIs.

Go to Maintenance.
Singnalling Troubleshooting PRI and Start a Trace.
Make Calls to create the failure scenarios occur. Then review the Traces.
Open a Case with Grandstream and upload Trace files and a GS Engineer will help you diagnose your issue.

I have a ton of experience with PRIs and have seen just about everyting.

Sometimes resetting the PRI. Either Reboot the UCM or Unplugge the PRI from the UCM and then plug back in can also help clear issues on the Line.

Ask the Carrier to run a Loop back test on the Line to look for errors. This will put the line out of service while they do this. The Loopback is managed on the local Smart Jack on your Customer Premise The Demarc point. The Carrier is responsible for everything up to this point.

Good luck,

Warm regards,
Jeff