UCM 6208 with HYTERA DMR repeater


#1

Hi, recently I have substituted an old freepbx with an UCM6208. With UCM6208 the integration between Hytera DMR repeater doesn’t work anymore. It’s very strange, the port, user, password are correct but the ID PHONE of the repeater doesn’t register on UCM6208. Anybody can help me? Maybe a flag on some options in the UCM6208. thank you


#2

The Hyrda is a broad product line and you provided nothing about the specific model, nor all the settings made in the UCM. Does the trunk show registered in the Hyrda? Are they both on the same LAN networks, is NAT set correctly, etc.?


#3

I just helped a client last week setting up the UCM with Hytera repeater as well. In the end, Hytera support had to connect to adjust some settings on the repeater. Everything on the UCM side was correct. I suggest you get in touch with Hytera support.


#4

Hi,
Hytera Is a Digital mobile radio repeater, my model Is rd965. Hytera and UCM6208 are on the same LAN. Hytera works correctly because previously was connected to a freepbx VoIP server and everythings worked well. See https://www.google.com/search?q=hytera+with+grandstream+release+notes&oq=hytera+with+grandstream+release+no&aqs=chrome.1.69i57j33.22277j0j7&client=ms-android-huawei&sourceid=chrome-mobile&ie=UTF-8


#5

Sorry, but a Google search is not very informative.

Take a network capture at the UCM and post a link to same so it can be examined.

Have you set Pbx Settings, Sip Settings, & NAT in the UCM to include adding in the local LAN?
Is the Hyrda in the IP blacklist?


#6


#7


#8

That is not enough. When using a register trunk, one side will send a REGISTER request and upon its receipt the server will challenge with a 401. The 401 is meant to cause the device sending the REGISTER request to send the request again but with its authentication credentials so the server can validate the request. Then, once validated, the server will allow the registration. I see that what you posted has the credentials in the request, but as I cannot see the actual pcap file, I do not know if all the screen shots are in the order that the messaging actually took place. I also do not see the contact headers to know if the messages are going to the correct IP (NAT).


#9

The hytera radio repeater logs as a normal user, ID/password/server ip and Port. It isn’t a trunk, only a normal user. Hytera and grandstream ucm are on the same LAN, so the nat should not be used. Is It correct?


#10


Configuration of ucm


#11

Hytera configuration


#12

Well, as you are not using any of the standard reserved LAN address ranges, knowing it is on a LAN was not obvious. I assume you also have the authID as well as user name set (they will be the same in the Hytera if the UCM extension is not set to be something otherwise).

If on the same LAN, NAT should not be a factor, but I do not know how you have the NAT settings set; is your LAN identified in both as being local networks?


#13

This Is the request


#14


#15

Hi,
I have tried everything, but doesn’t work


#16

This does not show enough.

It is showing a register request, which is then challenged (401) and then the subsequent new register request with the needed credentials, but there is nothing after so I do not know what the result was of the last register request.

You may be better off using a peer trunk if the Hydra will support it.


#17

Here It Is something strange… See a normal phone and the hytera. It looks like a loop in the request/response! IMG_20190610_162810|666x500


#18

219 Is a normal phone, 227 Is hytera


#19

Please just post the pcap file itself.


#20

capture-000B82D9B2D1.zip (38.3 KB) thank you for your help