UCM 6200 firmware 1.0.18.13


#1

I know there was an update for version 1.0.19.x to fix a video conference hack, does anyone know if they are going to update the 1.0.18.x with the fix(1.0.18.13 has the issue) or do all of my customers need to upgrade to 1.0.19.29. and if so, why isnt it clearer that the 1.0.18.13 has a major bug in it???


#2

go here download the changelog and find the answers to your questions:
http://www.grandstream.com/support/firmware


#3

There was an announcement and if you will go to the firmware site you will see:


#4

Yes, I see they updated the firmware for the Discontinued UCM6100, I am wondering why there is not the same firmware for the UCM6200. Is it going to be updated? Can i use the UCM6100 on the UCM6200?


#5

absolutely not, they’re different HW


#6

As Damiano indicated, they are two different systems and the 6100 is end of life with only maintenance firmware releases coming out to address specific issues. I am uncertain where you got the screenshot, but if you will look at what you posted for the 6100 release of 1.0.18.13 versus the shot I posted having 1.0.18.17, you will note they are different with mine being the more current. I suspect your browser cache needs clearing. Here is the 62XX and 6510 as of today -


#7

ty, i see the firmware for 1.0.19.29, my question was

“does anyone know if they are going to update the 1.0.18.x with the fix(1.0.18.13 has the issue) or do all of my customers need to upgrade to 1.0.19.29.”

i didnt think it was that difficult question, grandstream still offers 1.0.18.13 with no warning and its unclear if it needs to be updated to 1.0.19.29

I am hesitant to update features on someones pbx(18 to 19 adds features), it inevitably ends up with confused customers. it would be best to fix the bugs without adding new features

maybe it would be better to go back to version 1.0.17.x before the video conference hack.


#8

Again, the 61XX is only getting maintenance releases as it is EOL (end-of-life). The firmware that has the fix is 1.0.18.17 as shown in the screen shot I posted as taken from the GS Website. Hence; why I suggested that your browser cache may need to be cleared so you could visit the site again and see the current page with the updates rather than the page you posted with an older version from some time ago.

61XX versions prior to 1.0.18.17 have the issue; hence why GS indicated the need to upgrade to 1.0.18.17 immediately. It is a new threat so regressing will not fix it.

You cannot use the 62XX firmware on a 61XX as they are different devices with different hardware.

Download 1.0.18.17, backup the existing systems and then check the release notes to insure that you can go from whatever version is installed to the latest without having to install some interim versions first. If all is OK according to the notes, then install 1.0.18.17.