Trouble with HT801 and Australian ISP Dodo


#1

I am trying to connect an HT801 to the Dodo (an Australian ISP) network .
(I have tried this with the MicroSIP Windows app and it works, so I believe the credentials etc for Dodo are correct)

I have entered the following info

FXS PORT

Primary SIP server: sbc02a.mel.voip.iprimus.net.au
Outbound proxy: dodovoip.com.au
SIP user ID (the phone number assigned to me by Dodo)
Authenticate ID (the ID assigned to me by Dodo)
Authenticate password (the password assigned to me by Dodo)
Name: (my name)

ADVANCED SETTINGS

Firmware server path: firmware.grandstream.com (this worked in upgrading me from v1.0.33 to v1.0.41)
Config server path: fm.grandstream.com/gs

The device connects to my LAN ok; it gets an IP address and it also was able to download an update.

The status page shows this
MAC Address:
IPv4 Address: 192.168.15.150
IPv6 Address:
VPN IPv4 Address:
VPN IPv6 Address:
Product Model: HT801
Serial Number:
Hardware Version: V1.1C Part Number – 9610003611C
Software Version: Program – 1.0.41.2 Bootloader – 1.0.41.1 Core – 1.0.41.1 Base – 1.0.41.2
CPE – 1.0.4.19
Software Status: Running Mem: 21604
System Up Time: 11:02:27 up 2:46
CPU Load: 37%
Network Cable Status: Up 100Mbps Full
PPPoE Link Up: Disabled
NAT: Unknown NAT
Port Status: Port Hook User ID Registration


FXS On Hook 03xxxxxxxx Not Registered
Port Options: Port DND Forward Busy Forward Delayed Forward CID Call Waiting SRTP


FXS No Yes Yes No

CDR File: None
SIP File: None
Provision: Not running, Last status : Downloading file from url.
Core Dump: Clean

The device seems to never be able to register.
Any help would be greatly appreciated!


#2

Change the SIP service port/use a stun server - I take it you have a DODO Modem as well - MicroSIP will change the SIP port or use stun to get around the firewall, as I take it you have an FXS port on the DODO Modem tied to 5060 registered hard coded in the Modems firmware.

Stun Servers in Australia - possible to use : https://gist.github.com/mondain/b0ec1cf5f60ae726202e

stun.faktortel.com.au:3478


#3

Thanks for helping out.
For the moment, I have switched back to what I had before (i.e. NBN modem --> Dodo router WAN, no MiktoTik), so I can get some paying work done for this week.

I will then try the whole thing again.

My Mikrotik setup is (this is what I want to settle down on in the end)

NBN modem —> MikroTik WAN port

HT801 --> MikroTik LAN port 2
8-port switch --> MikroTik LAN port 3 (for the rest of my LAN devices)
Dodo router --> MikroTik LAN port 4 or the switch

The Dodo router is used for Wifi only. No DHCP, no VoIP.

Once I get back to trying this I will take screenshots of the HT801 pages and attach them here.

Thanks again!


#4

HFC / FTTN / FTTP / FTTC ? Do you want me to look at your Mikrotik config to help with the setup ?

Im talking about the DNAT

PFSense isn’t bad… just need to make sure that you set it up for SIP


#5

It is HFC.
I will switch back to the MikroTik setup this coming weekend and I will let you know then.

I am trying hard not to get distracted; I’ve already spent a lot of time setting up a home server on a DL350 G6, with Proxmox and a myriad containers with anything from pfSense (not needed once MikroTik is in), TrueNAS, Odoo, etc…)

Way too many distractions :slight_smile:

Many thanks again! I’ll be in touch at the end of the week


#6

Dodo had given me “dodovoip.com.au” which does not work (thanks to finite-state-machine from Whirlpool for figuring that out).
Using voip.dodo.com.au in ‘Primary SIP server’ seems to do the trick.

The HT801 now shows as registered but it still says ‘Provision: Not running, Last status : Downloading file from url.’

Also, on the MikroTik, I have opened ports 5000-65535 on the IP address of the HT801 for incoming udp and tcp.
(Once it is all sorted out, I will narrow these down)


I did a full reset and then changed the following (pls ignore the purple cursor)

(I am allowed one image per post, so I will create more posts for the remaining images)


#7

(cont’d from previous post)
Furthermore, in the AdvancedSettings tab, I changed the following

Do I need the ConfigServerPath? Can I leave it blank?


#9

(cont’d from previous post)

this is the status page


#10

(cont’d from previous post)
lastly, this is the MikroTik firewall setting


#11

The 1st question is - How does the SIP server know what IP to use when trying to respond back to the HT? Do you have a static or dynamic public IP?

If dynamic, then you need to enable STUN under NAT traversal. Then you need to input a STUN Server such as “stun.ipvideotalk.com:3478”. Then you need to tell it to use the WAN side for the IP.

Presumably, the HT is using the default for SIP and RTP in which case it is 5060UDP and 5004UDP. Yes, I saw the mention of cleaning up, but there is no need to open 60000 ports.

The config server entry can be blank if so desired.


#12

Thank you for replying!

I have a fixed IP address. Where should I enter it? I can’t see any obvious place to enter it.

Also, for completeness sake, if I ever end up with a dynamic IP, what should I do?
I can see that there is a field called ‘STUN server is:’ for the STUN server name but where would I specify that it should use the WAN side for the IP?

Thank again.


#13

Look for NAT IP or similar in the HT.


#14

It’s an HT801, my mistake, as there is only 1 port.


#15

I entered my public IP in ‘Use NAT IP’, in the FXSPort tab
Alas, it still says ‘Registered’ and 'Not running, Last status : Configuration update completed.
This is now different. Getting closer?


#16

I suspect the router.

You can also enable SIP options keep-alive with a 30 sec frequency.

Show the NAT section of the router.


#17

(
Murphy’s law struck! My mobile plan ended it’s monthly cycle tonight and is now auto-recharging the account. During this time, I can’t make any calls, so I can’t test if the HT801-attached phone will ring!
)

Re NAT in the router, there are no entries there. Should there be?

[UPDATE]
I added a NAT rule (udp and tcp)

General
Chain: dst-nat:
Dst Addr MY-PUBLIC-IP

Action
Action: dst-nat
To addresses: 192.168.15.03


#18

[quote=“nick-d, post:6, topic:53162”]
ip.dodo.com.au[/quote]

in the Mikrotik remove the firewall rules and use NAT source and destination so that you can prevent hackers getting to the ht801

Source=203.160.8.74 (voip.dodo.com.au)
Destination=192.168.15.103 (ht801)

Ports to use:
udp:5060 for sip
udp: default ports for rtp in the ht801

Then use 203.160.8.74 for the registration server primary and proxy - both 5060


#19

This is often well worth doing in my experience, it solves all sorts of issues with registration if you set the HT801 not to allow the registration to “drop-off” through timing out.


#20

I have now solved the problem.

I reset the HT801 to factory defaults and then I entered the following in the HT801 FXS page

Primary SIP Server: dodovoip.com.au (see note 1 below)
Outbound Proxy: sbc02a.mel.voip.iprimus.net.au
SIP User ID: voipxxxxxxx
Authenticate ID: <same as above>
DNS mode: SRV (however, I have not checked if this contributed to the success)
OPTIONS/NOTIFY Keep Alive: OPTIONS (however, I have not checked if this contributed to the success)
Use NAT IP: <my public IP>

and, for good measure, I also set the following in the ‘Advanced settings’ page
Firmware Upgrade and Provisioning:
Upgrade Via: HTTP
Firmware Server Path: firmware.grandstream.com
Config Server Path: <blank>

Note 1:
dodovoip.com.au is not a valid name that resolves to an IP address, as a number of people pointed out.
But, as somebody else also pointed out, it is only used a string to match against…

Many thanks to all that helped along the way!


#21