Transfer to non-working extensions return to tranferee?


#1

Hello everyone,

We are about to start using our new phone system (grandstream 6204 pbx with gxp2160 phones). I have extensions set up for phone, VM, IVR, etc. Everything seems to work as planed (meaning if you dial an extension with a phone you get that phone to ring and the party at that phone can pick up and talk to you)

What I need to change is that when an extension is entered that has not been set up I get a message
“server error please check your device”

I would like to change this message and wonder where I could do this within the pbx.
I also see an issue with blind transfers as if someone calls from outside the system and is transfered to an extension that isn’t set up they will hear this message (not the end of the world) and they will get disconnected (kind of a bad thing when you hang up on your customers for profits and yelp reviews). So is there a way to solve this? I don’t know how others handle this so just looking for options (bounce back to the transfree? bounce to another extension like a front desk where it is known to work?) With lots of extensions that don’t work, I would hope that there is a way to do this for all non-set up extensions rather than go through and create an extension then put in a call forward option. I would have to do this for like ~ 9000 extensions.

Thanks


#2

Usually it is voice prompt
http://www.grandstream.com/sites/default/files/Resources/ucm_voiceprompt_customization_guide.zip


#3

Thanks so much. So I can change this. Any thoughts on how to not hang up on people that get accidently blind transferred to an extension that isn’t set up?


#4

Search this option in UCM :slight_smile: (as it change position in different fw)
Search is top near wizard.

Blind Transfer
Allow callback to transferer when blind transfer fails


#5

Again Thanks! That search function is a game changer. I would have never found that setting.

So I enabled this, saved and applied changes. Dialed an extension, picked it up pressed the transfer button, dialed a non-setup extension 5732 and got the server error message. I was thinking it should have rung back to the transfering phone. Maybe I need to set up the phones as well?


#6

You tried ATTENDED transfer not BLIND.
In attended you will get message and you will not engage transfer at all (only hold).
In blind you sent call to that extension.

Check difference between them :slight_smile:


#7

Hum. I though I did blind but please tell me what you think. Here is what happened.

Dialed from extension 100 =>101. I put the call on speaker and then
I answered the call at 101
From 101 pushed transferred button and dialed extension 5732 and hung up phone
From extension 100 speaker I hear the message “server error please check your device”

I thought that if I was doing an ATTENDED transfer then I would hear “server error please check your device” from extension 101.

Does it sound like I did the wrong transfer?


#8

Just got some interesting feed back from GS ticket support.

Thanks for contacting Grandstream support center.

This feature only will work for the bussy and no response scenarios.

So I guess the scenarios where someone transfers to an extension that isn’t set up won’t work. Bummer.


#9

Submit a feature request to GS.

To me, the system should have an awareness of what the valid extensions are and should, in the event of an attempted transfer to an invalid extension, provide the transferor (sp?) with a error prompt about the extension requested and should restore the call back to the transferor.


#10

Makes sense to me. I would have though it would work that way by design, but I guess not.


#11

Design … yeah i see it a lot. It make you wonder if anyone check this design as they make hilarious errors there.
In that example it is obvious to everyone (beside designer) that all BLIND transfer should be treated this way, no mater where i forward it.