Switching between multiple WiFi networks

bug

#1

Unable to cleanly switch between multiple networks. Having to reboot the phone in order to switch from one WiFi network to another. I have multiple SSID’s in the office and was trying to see how easy it would be to switch between them. Selected the second SSID and it connected fine, but then when the phone was out of range from that SSID it would not connect back to the original SSID. Had to reboot the phone in order to get it to connect.


#2

Hi,

The current behavior is that if you connect to an SSID, it will keep the connection to that SSID (reconnect if disconnected due to weak signal or AP down situation). You can switch to another SSID manually by connecting to it. Your proposal seems to be that you would like the WP800 to be able to roam between two different SSID (known networks that had previous connectivity). We would need to evaluate the possibility of adding of this function.

Thanks


#3

I have not experienced this. I’ve taken the phone from one of our locations to another, and they have different SSIDs, when I arrive at the alternate location, the phone joins automatically w/o intervention… Now, obviously, there’s a point in time that it has no signal at all for 15 minutes (traveling between locations) - it may not be able to jump immediately between, but I haven’t had to “pick” an alternate network once it’s been joined the first time.


#4

I was able to get it to join the second network but it drops to no service before it even tried to grab the second network. No I know there will be a delay in grabbing the other network but twice it took over 5 minutes before it would grab and 3 times I had to reboot the phone. It should be able to determine which network has the strongest signal and switch if a call is not in progress.


#5

Yeah… That’s crazy long…


#6

Hi,

Your right, currently it will choose the other SSID if the current one completely drops out of service. Depending on the position of both APs, it may take some distance before the signal completely dies out. We will propose an idea to make the roaming aggressiveness to be configurable.

Thanks


#7

I set up the WiFI at home and all worked good. Coming back to work this morning it would not reconnected to my office WiFi. It would just say saved, then would go to disabled then back to saved. Had to turn WiFi on phone off, then back on for it to reconnect.


#8

We’re seeing the same situation with regards to not connecting to other networks. Our primary work network is in the middle of other work networks all from the same upstream provider. That provider has a wide area wifi network that you can use if you have an account. Great for mobile phones. We configured our WP800 to use our work network and this wide area network and connected to our work network. Then walked out the door to the pizza place. The phone lost connectivity to our network but never switched to the wide area network. Manually selecting it worked fine with a strong signal.

Maybe we didn’t wait long enough, but everyone is used to mobile devices that are aggressively switching to the strongest available configured wifi network when the current connection gets below a dB threshold. It would be nice to see that on this device as well, since it could literally take over as a mobile phone in a densely populate wifi area.


#9

Hi,

Thanks for the feedbacks. Just to recap the issues we are noticing here:

  1. When there are multiple saved WiFi networks, the phone is not switching to the stronger signal SSID when the current signal is low. The proposal here is that we should be able to configure the roaming aggressiveness.

  2. The WiFi is not reconnecting with known networks after completely lose signal with previous connected SSID. It’s possible a scanning timeout occurred during the transition from home to work.


#10

That is correct.


#11

Can’t really confirm #1 exactly because we only have control over one wifi network at our office, but we can confirm #2. When out of range of our work wifi, but in range of a second configured network, we must manually tell it to connect.