SSL certificate installation


#1

Hi

I’m having real trouble getting an SSL certificate installed into a UCM 6202 HTTPS web server.

I can upload the private key and a certificate without any trouble.

However, I can see no way to add the intermediate and root certificates.

I’ve tried appending them to the .pem file, but the UCM does not recognise them - the certificate will install, but when I run an online check for correct installation, it fails due to trust.

I’ve spent hours on this!

Any help appreciated.


#2

First the files need to be in the right format. It’s not simply renaming the file extension.

Also, the Root CA is not needed as all browsers have it built-in, however the Intermediate is and should be prepended to the Cert file.

I managed to get this working once but it was a pain in the a**. I wish they made a file upload that convert the files accordingly.


#3

I am using PEM files - from the XCA windows utility.

This thing is driving me mad - I generally don’t have too many issues with certificate installation on other devices. However, the UCM6202 has me stuck!