SOLVED: Outbound call from UCM6510 through PSTN gateway GXW4108


#1

Hi,

I followed the guide Configuring UCM6XXX with GXW410X from Grandstream to make Inbound and Outbound calls through the PSTN gateway.

Inbound calls work as expected: the PSTN gateway forwards inbound calls to the UCM, which then manages them.

Outbound calls on the hand do not seem to work. I configured a route, allowed an extension to use the route, but I have the voice message : “Tous les circuits sont occupés” (I’m translating: All circuits are busy).

Where can I start to look?

Thank you in advance.

Amazigh


#2

Packet capture as you must set something wrong.
Can you see call in CDR ?


#3

If you have multiple routes in the outbound dialling table enter a new route - like the following and move it to the top of the routing table:

Dial pattern: x.
Trunk: GXW4108 name
Privelege level: same as the privelege level for the telephone extensions that you want to use the trunk.

You should then be able to dial out unhindered. You can change the pattern to suit the local or national dialling scheme once you are able to confirm you can call out.


#4

Marcin,

You are right, the call attempt doesn’t even show in the CDR. I’m using Twinkle in Linux as the SIP client, the UCM is mainly used with SIP/UDP. The capture shows a SIP 401 unauthorized and a failed TLS cipher negotiation.

I’ll look that up.


#5

Scottsip,

I did move the rule at the top as you suggested, but to no avail. I think the issue is with the SIP client, which I’ll change.


#6

Correction: it actually shows in the CDR, but there is a protocol mismatch.


#7

Update: That was actually a SIP client problem (with Twinkle in linux), and a protocol mismatch.

It works fine with MicroSIP in Windows.

But whenever I dial a number, I get a dial tone from the PSTN line, as if the number is not dialed directly (I have to redial the number to make an outgoing call, which works). Any idea? Thanks


#8

1 stage dialing


#9

Exatly. Thanks you all. Problem solved.


#10