(SOLVED) Gxp1625 - Phone going in idle mode...and cannot receive call from outside


#1

HI guys, i recently buy a phone GXP 1625. Work ok but recently have some issues like this. If someone calling me from the outside work in a PSTN phone. the call cannot go true. In my office i have to make a call like at an extention. And soon as i hangup. The call could be made from the outside. Do you know a way to make sure the phone is not going in idle. And stay registered with our pbx. Thanks i submit also in support on the website.


#2

From a network perspective the phone does not go to sleep. Only the screen may dim, but the rest of the phone remains fully functional.

The issue you describe is the router and phone configuration not being correct. There are a few possibilities:

  1. You have a dynamic public IP and the router is picking up a new IP and the provider is not able to deliver a call as it does not know what the new IP is until…you make a call and the provider sees the INVITE and the new IP within same, or the phone tries to register (and the provider sees the IP in the REGISTER).
  2. The router has either a static or dynamic IP, but in either case, the IP has not changed (yet if dynamic), but the router ports are closed and the provider cannot get thru to deliver a call.

When you make a call, the phone is sending data packets out the router to the provider. The provider now sees the IP and he router, by virtue of allowing packets out, is now keeping the ports open in anticipation of a response (assumes port forwarding is not in place), but only for a short period of time and then closes same.

Does the router, where the phone is located, have a static or dynamic IP? This step determines the best method for setting up your phone.
,


#3

Always have a static Ip.


#4

In the phone -

In the network settings change the NAT type to keep-alive and if there is a setting for frequency make it 20 or 30 seconds.

Look for a NAT IP setting and when found enter in the static public IP of the router.

In the SIP settings, make the registration time 60 seconds (2 minutes).

The keep alive is intended to keep the ports open on the router, but you could also reserve or set a static private IP for the phone and then port forward in the router. The latter being the better way.

You should also look into the account settings, security and then enable accept from sip proxy/server only (or words to that effect).


#5

I found the problem…

After many call and email and else. We ave found that under ACCOUNT # / Network Settings / NAT Traversal / KEEP ALIVE

So now no mather if the phone stay on idle mode we can receive call. And we could receive call.

Thanks to all. bbvc


#6

Please insure that you enable one of the security modes in order to prevent ghost calls. This was mentioned in the last sentence of my last post. If you fail to do so, expect to get many, many, many calls that will ring and drive you nuts.