SIPS and TLS HT812 not accepting 200OK


#1

Hi,

i have the latest firmware installed on the HT812 and some of my current configuration is below

SIP Enabled (I would prefer to use SIPS)
TLS Selected
SRTP Enabled and Enforced.

If i use SIPS the telephone rings however, i am unable to hear them and they are unable to hear me. The call hangs up after 30secs or so. If i change the settings to use TCP and SIPS the connection is sucecssful.

I have engaged the VOIP provider and they confirmed the same results, using SIPS and TLS they responded back as follows - “we found that the Grandstream was not acknowledging a 200 OK message, which caused the calls to drop”.

is this some sort of bug in the system and what methods can i do to help pin point the issue and work with the VOIP provider?

thanks


#2

Which Voip provider
What is the firewall in place at the HT812 end
What does the firewall settings look like…


#3

The VOIP provider is here in Aus called CrazyTel. They were able to reproduce the same issue in their labs and i can from my house. I don’t have a FW but the HT812 is connected to my R7000 router (SIP-ALG is disabled).

thanks


#4

Netgear R7000 Nighthawk AC1900 Smart WiFi Router

That the Router ? what does the port forwards look like ?


#5

don’t have any port forwarding rules configured on the router.


#6

That will explain audio issues but sip registers okay

Have you checked the following?

https://knowledge.crazytel.com.au/en/knowledgebase/article/grandstream-ata-setup-guide

I do not understand why you have set SIPS, TLS unchecked,

Ensure that your router allows from the following IP
Address: 103.137.56.33

I would set a reservation in the DHCP settings of the router for the HT812 to always be a particular Ip and port forward to that Ip…

That way it will only ever be crazy’s sip server contacting your HT812… Forget SIPS etc… the government has all security algorithyms anyway… So man in the middle will only be from the G…


#7

Yes, i have followed the guide.

TLS with SIP = Works
TCP with SIPS = Works
UDP with SIPS = Works
TLS with SIPS = doesn’t work

Crazytel has also reproduced the issue in their lab

ok thanks for the info. i do have SRTP enabled.


#8

Actually, talk to the company that provided the Grandstream and ask them to raise a ticket with the Helpdesk.


#9

i bought this device from an online store.


#10

Id suggest to get back in contact with them as I stated.


#11

Do you have a static IP or dynamic as public.

If dynamic did you enable STUN and set a STUN server? If static did you set the HT to use the WAN IP address and then input the public IP in the NAT IP setting in the HT?


#12

the HT is just getting an IP address from my router (private). Do i still need to do those steps when TCP and SIPS functions?