Setting Outbound Caller ID's


#1

I thought i had this setup properly as it hadn’t been an issue until a month or so ago. However whenever anyone calls out from our UCM system, the outbound call displays as a call from Romania. We are in Canada. I have setup the phones to display our proper shop phone number including the 1. I have set up the Voip.ms to receive and use whatever the PBX sends it, and I have tried to configure the PBX to use what each extension is sending but somewhere it is getting mixed up. I checked the CDR on the UCM, and outbound calls show up as “Kelly 1001” being the user. Not sure what setting is wrong or right anymore. I did try and adjust the SIP ToS settings on the “Send Remote Party ID” and “Passthrough PAI Header” but it worked once then reverted back to Romania.


#2

Update; I have checked “Send Remote Party ID” and unchecked "Passthrough PAI Header”, thinking that was the issue as it seemed to have worked. But think there is more that is needed. As when i first enable and saved the settings, I tried calling my cell phone from my voip desktop phone and it showed up properly. However I tested it again a few minutes later and it was back to Romania. So then I checked “Trust Remote Party ID” and tried again and it worked, but then retested 5 mins later and back to Romania. So then I unchecked “Trust Remote Party ID” and again it worked, but once again few mins later Romania. Arghhhh.


#3

Hello Mr. Kelly,

I think there is a possibility of incorrect settings in the SIP provider that you are using (voice.ms).

You can check the settings in the SIP Provider

Maybe the problem is related to the location of caller id or there is an incorrect setting in your account routing related to the location of “caller id” or something like that

I hope this can help solve your problem


#4

Ray4778 is likely on the right track, here is some info about CID that may help-
https://wiki.voip.ms/article/Caller_ID


#5

@KelKix I use voip.ms without issue in this regard if I set the DOD on the VoIP trunk using the default settings.

I suggest you remove the leading 1 on your DOD as if I recall voip.ms is expecting 10 digits.

If you want to post screen shots of your setup it may be easier to diagnose your problem. Or, you may wish to contact voip,ms tech support as they can assist you with why your are getting these results.


#6

When you say DOD, you are referring to the extensions CallerID number, correct? As to make this work previously I had to add the leading 1 to get it to show properly before as it use to come up as Indonesia. But now it is Romania. So, I am assuming that Voip.ms has possibly changed their acceptance criteria? I will test without the leading 1 and report.

Also, I have check the SIP on voip.ms and it is set to have the PBX tell voip.ms what number to display. Which is what I want.


#7

Ok I talked to Voip.ms, which in the end did not help. Checked some settings but overall same issue still. This issue is temperamental and ongoing. Calls from my extension are showing up correctly, but next time display as unknown. Calls from another extension to my cell phone display as romania, but calls to landlines show up correctly, yet calls to a different cell phone number but same provider show up correctly.


#8

No. I am referring to the DOD on the SIP trunk. I have run into issues at voip.ms when this was not defined or improperly defined.

Also, I never put anything into the extension CallerID field; never found a need…


#9

See attached screenshot, is this the DOD that you refer to?


#10

No, go to the sip trunk page and note the following:


#11

Oh i see. Ok, i do not have any DOD’s currently setup


#12

Well, I think I may have figured out why. In the Voip SIP trunk settings, somehow the “Passthrough PAI Header” was unchecked. I tested it and so far seems correct, but like before, this thing flips back and forth.


#13

Same here. I use VoIP.MS with DOD. No issue. UCM6510 latest Firmware tested.


#14

Ok, so what are you guys putting in the DOD spot?


#15

10 digit company DOD and company name with all extensions assigned.


#16

Well I tried that and now I get Server Error. So i reverted back, and at least can call out, but once again I am showing up as Romania. At this point, if anyone wants to send a DM regarding digging into this further with me. I an open to offers.


#17

The issue seems to be somewhat of a shotgun approach looking for a resolution to a question that hasn’t really been asked -
Exactly what do you want the CID to represent? Do you have a DID set for each extension and do you want that DID as the CID for each? Do you have a common business number and you want that number to be sent regardless the extension calling out? or, is there a mix where some have an extension DID need and others the business DID?

1st, VoIP.ms requires that -
North America calls with Caller ID not containing exactly 10 digits will be rejected
Caller IDs must be associated to the account.

2nd, if you only need just the business number for all calls, then simply set this in your VoIP.ms portal which will override all PBX settings.

If you need different DIDs, then we need to set the VoIP.ms account to use a device that provides its own CID and then we need to know -

What trunk related settings are established with regard to CID variables-
image
What is set with regard to keep trunk CID or original CID?
What is set in the DOD settings for the trunk?

What is set in the extension settings in the UCM for CID?
What is set in the PBX settings, SIP Settings, ToS for RPID and PAI pass-thru?
What is set in the PBX settings, General with regard to global CID?

All of these are related to CID and as there have been a number of changes in the meantime, their current state is unknown.

Each setting alters what is included in a header and impacts what the provider needs and where they need it.
Most providers will expect to see a CID in the From, PAI or RPID fields and the question is which one do they want?

So, in the following case my trunk From User is seen in the From header below, it represent my primary DID ending in 999. I also have a DOD set for my extension and as I have changed it to a fictional number, you will see this in the Contact Field and ending in 1212.


I have no other CID settings set in the UCM.

If I enable RPID, then RPID is seen in the following capture with the DOD number I used ending in 1212,
image

So, the key is knowing what to send and in what position to satisfy the provider and this may require some testing.


#18

Ok that is helpful, and I may be cross contaminating my UCM with all the back and forth and now not sure what is what. Might be easiest to describe what the game plan is.

I have 3 office locations, 1 in Canada, 2 in Texas. Each has its own GS UCM, with the only variable being that the 1 location in Texas, there is actually 2 sister-companies operating out of. So they have 2 main DID’s and I attempted to set them up to have separate DOD’s.

In saying all that, when I initially set up the phones I used the default settings of the UCM and did not set a DOD on the VOIP trunk setting. I had seemed to be able to set the CID on each extension, therefore allowing the Texas location to utilize one UCM. We do not use Direct lines to our desktop phones, our company is not large enough to warrant that, and personally most people just default to calling their cell phone anyway.

So for our phones in Canada, I just programmed that the Inbound route would go to reception. For outbound, I had each extension have our +1 & the 10 digit phone number in the CID. We have 9 extensions at this facility. As this had seem to work for displaying properly on my cell phone and others. That seemed to have changed recently, unbeknownst to me. But as I am still learning about the VOIP thing I likely had it coming too, as I don’t believe this was set up properly. What I want is for our Canada shop UCM to just display our company name and company phone number for all outbound calls from all extensions. Like I posted earlier, I did try and setup the DOD in the VOIP trunk, and my VOIP providers CDR show this now, but when I call my cell phone to confirm, it still comes through as +43 (Romania).

Once I get this cleared up, I do want to apply my better understanding to the USA facilities phones. But for now I am focused on Canada UCM.


#19

I think I saw somewhere in this thread or another thread that voip.ms requires exactly 10 digits, no leading digits. Area code (3), exchange (3) and number (4). That could be your remaining issue.


#20

I changed to 10 and same issue. I was just pointing out the fact that somehow the initial way I had it worked. Again, not saying it was right, but as I have now adjusted it back and forth with each forum topic that I could find. I am reverting back and attempting to understand the core setup that it should be like.