Semi New but need help with no audio


#1

Ok so my client wants to use the soft phone. When we are on cellular the softphone does register and we can dial internal and external numbers but we have no audio on either side. What am I missing?
I have 5060 open static ip. I just can’t figure it out.


#2

Have you opened the RTP ports too?

Have you enabled NAT on both the extension and the device?

Have you configured the “External Host” and enabled “Use IP in SDP” under PBX -> SIP Settings -> NAT ?


#3

… finally, it is necessary to activate the Stun on the app.


#4

ok RTP is open 10000-20000

Nat is enabled on both extension and device

I’ve got the external host with the public IP we use

and Stun is turned on in the app for stun.ipvideotalk.com


#5

Check your router and insure that any SIP ALG or SIP helpers are disabled.
What type of connectivity for phone service - analog or SIP? If SIP, any issues?

If still not functional then-

Take a capture at the UCM when making a call from the WAVE and look at the contact header of the WAVE.

Also,


#6

Ok checked and sip is disabled. I’m using sip for connectivity and no problem with it.

Here’s a copy of my capture
capture-000B825C4EF0.pcap.zip (14.5 KB)


#7

OK, kindly do a similar call and capture when making a call from a normal extension that is on-site with the UCM.

I am not seeing any audio in the capture to include that which should be coming from the provider, yet the messaging seems to be normal with regard to connect and contact headers. However, I am somewhat assuming this as while I see the public IP in the messaging, I have no way to know if what the message shows is what the real IPs are. I am hopeful I can compare the two calls and see.