Screensaver fails to function when "on if no active VPK" option is set

ip-communications

#1

If I have screensaver set to “Yes” along with the option “Disable Missed Call Backlight” the screen saver works predictably well when the phone is idle.

However, I’d like the phone to wake back up whenever a BLF (monitored extension) goes into “in use” status. I tried turning on the feature “screensaver on if no active VPK” but unfortunately the result is that the screensaver becomes disabled permanently even if all the BLFs are idle for a very long time. The other VPK types in use are speed dial, transfer, and multicast paging.

I am inclined to report this as a bug because flipping the Screensaver setting back to “Yes” didn’t even get the screen saver working again. I had to reboot the phone to be able to get the screensaver working again after my attempt to use the “on if no active VPK” screensaver setting.

Any ideas?


#2

having the same issue, have also disabled missed call backlight, anyone have a suggestion?


#3

I came up with a partial workaround that I’ll share, but first I am curious to know, what version firmware are you running and on which model phone? Mine is the GXP2135 and there have been many version updates since my original post above. I was curious to know if you are still having this problem on one of the newer versions. If so, I would be inclined to open a trouble ticket with Grandstream about this non-working feature.

As I pointed out above, If you set Screensaver to “Yes”, it works predictably well. Use the “Yes” setting, then go to the admin configuration GUI, Settings->Call Features page, and enable the feature “Enable BLF Pickup Screen”. This setting will wake up the screensaver whenever a BLF goes into the “ringing” state. Unfortunately, if a BLF goes into the “in use” state the phone still won’t wake up. But at least this is a partial solution to the non-working “on if no active VPK” screen saver function.


#4

the model is 2170, latest firmware Version 1.0.9.121,
i will try this thanks for the response.