Screeching Tones on Incoming Calls/ Outbound Calls stop working


We have a UCM6204 (on latest firmware) connected with 4 POTS lines (3 Voice, 1 Fax) with GXP1630s (latest firmware) with an issue that I can’t for the life of me figure out. Starting a few months ago, every 5-14 days we can’t receive incoming calls. Callers hear a screeching tone for as long as the call is connected. When this happens the answering extension never rings and there is no record of the call in the CDR. A reboot of the PBX fixes the problem for a seemingly random amount of time before the issue arises again.

I have tried looking in the logs to see if I can figure anything out, but I don’t have the most experience with the system and can’t find anything that sticks out. I have tried reinstalling the firmware. I thought the fax machine was causing issues so I disabled that analog trunk and unplugged the fax machine. I enabled Fail2ban and dynamic defense thinking that the problem was a security vulnerability. I have looked in the firewall logs to see if anything is being blocked that shouldn’t be. Quite frankly I am stuck.

The system has been installed for several years without issue. The issues have arisen in the last 5 months or so.

  • does it do it on all PSTN lines§?
  • when this happens have you tried to remove the PSTN line from the UCM and connect it directly to the analog telephone to understand if the problem is present on the PSTN line on the operator side?
  • correctly done the regionalization and the setting of the impedances? (I use the semi-automatic method)
  • tried to delete a PSTN on UCM and recreate it?
  • tried UCM format factory as a last solution?