Request for Assistance with Caller ID Configuration Issue on Grandstream 6204 via AMI


I am using the Grandstream 6204 and attempting to configure it through the AMI (Asterisk Manager Interface). However, I have encountered an issue when dialing external numbers through our extension. The PABX (Private Automatic Branch Exchange) system is changing the caller ID to the SIP username.

Upon reviewing the AMI log, I noticed that I dialed 1111111111, but the PABX changed the caller ID to +9772222222, which is my SIP username. Consequently, when configuring the AMI into my system, it recognizes +9772222222 as the external call number.

To resolve this issue and ensure that the dialed number appears as the caller ID, please advise on the necessary steps or settings adjustments.



i have already contacted the helpdesk multiple times . they are not responding properly


Grandstream are the manufacturer, we are mostly users here… what do you want from users who are not paid by Grandstream, when you have contacted Grandstream support?


opened tickets in dec 2022 still not resolved


problems and perplexities must be sent via Ticket, this is only a user.user forum


The way I see it your choices are to use the Grandstream GUI or Go to the Asterisk Forum and ask for help.


why do you want the dialed number as the caller id?? you can set it to whatever you want, but if i see myself calling me, i wont answer…

the grandstream ami commands are lacking details, asterisk has the details for the commands, the options for originating a call is below, the CallerID is the value you want to change

Action: Originate
ActionID: <value>
Channel: <value>
Exten: <value>
Context: <value>
Priority: <value>
Application: <value>
Data: <value>
Timeout: <value>
CallerID: <value>
Variable: <value>
Account: <value>
EarlyMedia: <value>
Async: <value>
Codecs: <value>
ChannelId: <value>
OtherChannelId: <value>