Remote phone hold and park issue


#1

I set up a remote phone. There is only account 1 which connects to an extension on the remote Ucm 6208 and a few vmpks which are blf for a few remote extensions on the remote UCM. It seems to work fine .The problem is that I set up call park blfs and they dont work . Then I tried just the phone hold button and the forward soft key and that also doesn’t work. As soon as you press any of those buttons ,it just drops the call. On a local UCM connection the phone works with hold and call park. What am I doing wrong ?


#2

please set the extension up as an iax extension as your firewall is blocking traffic by the sounds…


#3

i tried but it doesnt seem to work at all as iax , only as sip .


#4

Try using Zoiper on your computer remotely as an IAX extension, make sure that your IP is white listed in the UCM and the Router with appropriate port forwarding.

Test again and verify.


#5

I set the phone to use NAT and STUN and the hold and call p[ark now works, But now I see the account getting discinnected and reconnected . I cant find the setting to set the stun server .


#6

What brand is the Router at the UCM end and the Handset end?

Have you performed the Port Forwarding in each router to allow communication?


#7

I have done pirt forwarding at the Ucm. The phone works and I can access other remote extensions . Its just the hold forward and call park that are having the problem. When I enable Nat ir Stun on the phone itself , it seems to fix that problem, but then the account of the remote extension seems to go on and off .


#8

The remote phone, is it also behind a firewall and is does the remote location have a static or dynamic public IP. Assuming that there are routers/firewalls at both locations, do they both support the use of a VPN?
If the remote site is using a dynamic public IP, do you have a FQDN for same?


#9

Try to turn on in the phone settings “Enable OPTIONS Keep Alive” under the account, sip settings and then basic settings. This fixed a remote ext I had doing the same thing.


#10

Turned on the Enable OPTIONS keep alive and still all calls drop at exactly 31 seconds .


#11

well this is a nat issue and look to the firewall(s)

What does the ucm look like under NAT side of things ?


#12

First clue is that my android softphone works remotely . Wouldnt that suggest that the UCM is set correctly and it must be a setting on the phone ? The UCM has the dyndns address and the softphone works perfectly . Its the 2170 that drops after 31 seconds


#13

Nope… not at all… Android is using the mobile carrier… and possibly using some form of stun which gets around Nat issues

The 31second drop points to a NAT issue.


#14

I have tried to set the phone to use STUN in network settings Nat Traversal ,but no luck still 31 seconds . I tried setting to AUTO and to KEEP Alive . What else can I try ?


#15

Both Firewalls - check the port forwarding.


#16

I added the public IP of my remote phone in the Nat settings of the UCM and that seems to have fixed it . The grandstream user manual is confusing as it doesnt state what ip to add in the box called local network address in th UCM


#17

When I wrote that you should have looked inside the UCM which you did and rectified the NAT issue which is great …

Solved.


#18

Thank you for helping . I find the help on these forums to be worth much more than the Support I get from Grandstream tech support . My remote site has a cable modem that is not static . It doesnt change often ,but it does change the ip once in a while . I do have a dyndns addtess but the UCM wont take it . It only allows a numeric IP address in the local network address box of the Nat settings


#19

I tried Zoiper android softphone by connecting to a cell mifi not on the remote network that I entered in the UCM . Calls drop after 31 seconds . I set the Zoiper settings to use stun.ipvideotalk.com It registers and works but drops call at 31 seconds . I tried dialing an extension . Same thing , drops at 31 seconds . The ucm doesnt see the cellular ip and obviously I cant enrer it because it always changes , What now ?


#20

I did a little test . I found the public ip of the cellular connection in the extension of the UCM . I then entered that into the local network address box of the NAT settings in the UCM and yes then the Zoiper softphone worked more than the 31 seconds . But thats obviously not a solution as this cellular ip address keeps changing constantly .