Remote extension working only with LAN not in WAN


#1

Hello: Can you please help me with the following issue. I would like to set set up a remote extension in my UCM6102. I have updated the firmware of the UCM to the latest available.
The problem I am having is related to the remote extension ( GS Wave) registering only when my cell phone is connected to the local WiFi network. When I go outside GS Wave no longer registers.
I have forwarded in my router Ports 5060, 5061 from my Static public IP to my local UCM LAN IP , and have set up parameters in the NAT options as directed.
The UCM is set up as Switch and the router is connected to the LAN port.
I looked at the Extension when connected through the LAN at it shows my public IP Address with port 49383.
Also the Firewall in my computer has been disabled while testing.
What do you suggest?
Thank you.


#2

with the Switch configuration there is no distinction between Lan and Wan, both are LAN.
You have to do the correct NAT of ports etc…
I advise you not to open NAT to everyone but only in ACL if you don’t want to receive almost immediate attacks. And to update UCM6100 to the latest FW release.
Look at the document below;


#3

Thank you! That worked for external calls using GS Wave but my local phones do not register now with the PBX. If I change the Bind UDP port (5060) to the the same port as the NAT External UDP Port: (5060) the local phones work but not the external ones, but if I change the Bind UDP to 5061, the External phones will work but not the internal ones.
What do you think is wrong?


#4

I think first make sure you’ve made the NAT rules in ACL, if you don’t want to have any surprises sureu, then I think you’re confusing the SIP recording port with the listening port.


#5

If you look at the PBX Settings, SIP Settings and then both the General and TCP/TLS tabs, you will note that 5061 is typically a TLS function. Are you using TLS?

Where did you change the settings to bind to 5061? Also, did you change the phones internally to talk to 5061? Not that you should at this point.

My take is to return the settings back to their default so that the internal extensions work as I assume there are more of those than there are external phones. It is easier to focus and fix one phone rather than many.

You indicated that the WAVE was registered, but what about it did not work? The port you see is the translated port that the cellular carrier has used in delivering the messaging.


#6

The reason I changed port 5060 to 5061 , was because I could not get GS Wave to communicate with the PBX through that port.
What I did was to open port 5061 in my router, disable TLS and change Bind UDP Port to 5061. That works perfectly until I reboot the PBX. When I do that the local extensions cease to work.


#7

I did not change the internal phones to 5061. Should I do that?


#8

No. Already suggested you leave everything at the default settings and focus on the Wave. Leave the WAVE at port 5060 and just change the transport to TCP and see if that helps.


#9

Thank you! I changed it to TLC and it worked!!


#10

TLC? :disappointed_relieved:


#11

#12

TLS propably :slight_smile: