Redux: Outgoing Caller ID is Restricted


#1

The forum seems deserted. Let’s hope that’s not the case.

Reference this post from ages ago:
https://forums.grandstream.com/t/outgoing-caller-id-is-restricted-twilio-solved/33143

I have the same symptom. I have a theory as to how to fix it but not sure if I can with the Grandstream device.

My PBX does not allow me to set the User ID to the phone number. It has a string that correlates to a username and forces me to enter letters. This value works in SIP - I can make and receive calls, it’s just the Caller ID.

Apparently, something in the Grandstream firmware changed to use the User ID for caller ID. Problem is, if you can’t make that numbers, the device doesn’t know what to do about it.

So. I need to figure out how to get this resolved - where I am not able to give it a numeric value for User ID.


#2

the forum is not deserted as you see.
A post from 3 years ago makes no sense to comment on it today.
Grandstream has in force the security policy of all vendors now, so in addition to the user and the pswd you can also differentiate the auth id.
If you have other vendor’s product that does not support auth id you should contact that product’s support. But I would like to give you a couple of parameters.
1 - auth is not mandatory if not set, so you can try leaving it blank
2 - you don’t really understand what you want to do, but if you want to put two voip servers in dialogue you can try to do it in peer.

Good job


#3

1st, are you using Twillo?
2nd, where do you see the term “User ID” in the PBX or phone?


#4
  1. No, not Twillo. I am using Phone dot com and OnSIP. OnSIP is the one I most care about, but ideally I would resolve them both, they both are affected. On the Phone dot com side I don’t get any option to change the IDs.

  2. SIP User ID is present on both the phone and the PBX. That’s the value that (based on that thread I referenced) should be the numeric phone number in order to get the Grandstream to actually send the caller ID, for some reason. And in the phone UI, it even says on the hover that it should be a phone number. But on Phone.com and OnSIP, it is a username value, not a number, that is used.


#5

No need to be smarmy.

First of all, we’re not talking about “Auth” ID. We’re talking about USER ID.

The Grandstream interface prompts for:
SIP User ID
SIP Authentication ID

Second, I said reference the post to help you understand the symptoms (Outbound caller ID is Restricted) and the fact that it’s the phone doing it, not the SIP provider. My post is to detail that based on the symptoms and my analysis, I know why the phone is doing it, but not how to resolve that.

So prospective solution 1: figure out what firmware broke it and try to roll back to previous and see if it works. If it does, report to Grandstream that the firmware broke it and see if they are willing to fix it with a new firmware. Or, if it was intentional, ask Grandstream why they changed the behavior and what the new settings need to be that are compatible with all SIP providers, not only legacy or physical/on-prem ones.


#6

I don’t know what you mean,
I gave you some parameters to try out above.
The translation may not be reliable, in any case if you want to try it.

Good work.


#7

OK, I was a little dense as I see it on the phone (DOH!), but I do not see it on the PBX trunk settings., so maybe I am looking in the wrong place. Can you point me to it?


#8

I have a ticket back and forth with GS Support and it seems that the software has changed the interface quite dramatically betwixt models.

I am using a 3380 and under the General tab for each Account, I have Account Registration --> SIP User ID and SIP Authentication ID.

OnSIP uses a straight text value for User ID and Authentication ID, two different values. They do not support numbers in the field.

According to GS Support, the phone should automagically pull whatever the Caller ID is from the SIP provider.

According to OnSIP support, their side is set up correctly.

SO for whatever reason, the phone is not getting the right information or if it is, it isn’t using it when placing outbound.


#9

I guess I am confused.

The post is under the PBX heading and you mentioned - “My PBX does not allow me to set the User ID to the phone number.” I assumed you were using a UCM as the post you referenced is listed under the 62XX/65XX heading. Would I be correct that you are connecting to a hosted system at OnSIP?


#10

Yes - I was referencing that post as a pointer to the issue and the background as to what changed on the Grandstream side. Nothing to do with UCM, nothing to do with Twillo. Just that it’s the same symptom, same issue (firmware appears to have broken the ability to do it), etc.

The Grandstream device is connecting to OnSIP directly, yes. OnSIP is the PBX, not a physical/local PBX. Which means I can only do what their side lets me do. But the caller ID is enabled on their end and calls DO work from the phone in and out. It’s only outbound caller ID that the Grandstream isn’t doing right.

OnSIP (the PBX provider) does not allow numbers in the User ID field. Thus, I can’t give Grandstream numbers in its User ID field. Which (according to the reference post) is the only way to get the caller ID to work.

I don’t know that it is - but it’s at least worth trying, if I can figure out what changed where and why that resulted in needing to have numbers in that field in the first place (on the Grandstream side).


#11

And have you seen the following:

Typically, CID is in 1 of 3 fields - From, PAI or RPID.


#12

Actually it’s solved. It WAS the Grandstream, but not the field I assumed.

Theory is that it didn’t like special (non-alpha) characters in the Display Name field. Clearing that field allowed the number to at least display out. I set back alpha-only and it’s still working, so I’ll wait until after databases have been updated.

But for anyone else looking, the Display Name field is worth looking at at least. I wouldn’t have thought to check that field.

Kudos to Grandstream’s support team.


#13