Recovery Incomplete when attempting firmware update

ip-communications

#1

Attempting to update GXP1625 phone from 1.0.2.4 to either 1.0.2.27 or 1.0.3.6 results in Recovery Incomplete and fails. Using TFTP for the upgrade. Please help.


#2

I fixed my own issue. The phone and tftp server were not on the same VLAN. Once I moved it to the phone to same VLAN the phone updated properly.


#3

Well, I thought this fixed the issue. Moved the phone to a different VLAN and setup a TFTP server on the same subnet and still getting Recovery Incomplete. I’ve also tried HTTP and same error occurs. Any ideas.


#4

From my experience with these phones, that is a known bug.

When i upgrade the firmware and get the message “Recovery Incomplete”, i turn off the phone, then turn it on again and when the phone starts, I always have the upgrade complete with the new firmware.

In my deployments, it happened when upgrade from the 1.0.2.4 firmware like you, but not always …


#5

Hello!
I have same trouble with GXP1625 phone.
Current installed firmware 1.0.2.25. Im tryed upgrade to latest 1.0.4.17 by tftp, grandstream http server and my own http sever,
but each time I received same result: “Recovery Incomplete”.
I found 1.0.2.27 firmware, but result the same.

How to fix this error and upgrade phone?


#6

Brand new GXP1630 phones, straight out of box, with 1.0.2.22

We have the same “Recovery Incomplete” when attempting upgrade to 1.0.4.17 on GXP1630 with firmware 1.0.2.22

Phone initially didn’t appear to update from Grandstream servers.
Then set the firmware update URL to our local HTTP server, and they updated. only to then report "Recovery Impomplete"
Rebooting then still at 1.0.2.22


#7

We still continue to have a heck of a time upgrading these phones. The strange things if I move them to a different switch they will upgrade. Can’t seem to attribute it to anything, same VLAN, same TFTP server no changes in the config. Anyone else running into this?


#8

It seems this issue was caused by LLDP running on the phones. As soon as LLDP is disabled, the phones update firmware properly! Anybody know why this might be the case?
Thanks


#9

Hello guys,

Recently our company bought 70+ gxp1628. In the first step we have installed almost 55 phones. Two of them was not alived the firmware upgrade. One of them was stucked in the “Firmware Update - Initializing…” for more than 40 minutes. The other was stucked in the upgrading proccess.

Very similar situation happend to me with another gxp1628 few months ago.

In all of this three cases phones had the 1.0.2.27 version of firmware. But I have to say that other 50+ phones had the same firmware as well.

I tried to do steps from the last ticket. So turn the phone back without any UTP connection. I was unlucky because these two phones still stuck in the “Firmware Update - Initializing…”

Iam worried because last time the grandstream support told me that this is unique situation. But I think that two phones from 50 is not so unique.

How can I be sure that in the future upgrade I wont break another phones?

Im still waiting for the Czech language improvement discussed in my ticket. Also Im waiting for the fix of another bug.

But how can I be sure that the upgrade will be successful after release of the new FW?

So we will have almost 100 phones in our local LAN. The firmware location is also in the local Lan.

Thank you for any reaction.


#10

I just reply to my own comment:

  1. The phones are powered by PSU (we dont use PoE)
  2. On the display of both phones was exactly “Firmware update - Initializing…” First SIP key account lights RED and six speed dial keys lights GREEN (from the bottom)
  3. Phones are up for 10+ minutes and still in this state (“Firmware update - Initializing…”).

When I tried to power on the phones with UTP connected cable and I waited a while (few minutes) it jumped to screen “recovery incomplete”. DHCP assigned IPs to that phones.

I tried this: Turned on the phones without UTP. Both phones stucked in the state which I mentioned above. After few minutes I connected these phones to PC (directly) In that PC was DHCP, TFTP with firmware. Phones started downloading the FW. After that the phones were rebooted and now it seems that everything is OK. The firmware is current 1.0.4.22


#11

I also have the same issue and one phone I cannot get off the “Recovery Incomplete” screen with no ability to boot the phone. Anyone have a way to get it out of the firmware upgrade process?


#12

I also faced similar issue with one GXP1628. For me helped this:

  1. Turn on the phone withour UTP cables
  2. Wait for cca 10-15 minutes.
  3. After that it should recover from this state.

If not, contact GS support. I hope it will help you.


#13

Hi All,

Please help me to rectify the problem in GXP 1620

I am getting " Recovery incomplete " message in the display after " Firmware update - Initialising".

FYI I have not tried for any firmware upgrade.

My vendor has informed that this problem can not be rectified and need to through the phone.

Can any one help to rectify the problem. Its real challenge for me.

But, I do not have any clue to rectify the problem. :frowning:

Thanks,

Mangal


#14

It mean firmware is damaged and recovery file is not available.
Most cases unit can be fixed with provided firmware, but this need checking packets from where phone search firmware, or use option 43/66 on DHCP to provide path.


#15

Hello everyone! Sorry for my english)

  1. Download tftp32 or tftp64
    you need only enable TFTP Server and DHCP Server. In TFTP Server select folder “c:\tftp”
  2. Download Firmware of your phone from “http://firmware.grandstream.com/Release_GXP16xx_1.0.4.55.zip”
  3. Extract your FW to folder from #1 gxp***fw.bin
  4. UTP and Power to the VoIP phone
  5. FW updated :wink:

#16

Hi
i have tried exactly as mentioned above above post not been passed.
any more way to load the FM.


#17

Phone get ip by DHCP or static ?

Best solution is usually to plug phone directly to PC and scan network card via wireshark to check what and where phone sent. Based on this we set up lab condition o resolve problem. You need more then basic knowledge to do it, or you need at least add here pcap so other expert can say what and how to set.


#18

hello

How did you do this??.. In that PC was DHCP, TFTP with firmware.


#19

Phone <- cross/normal cable -> PC
Start wireshark and see what packet phone sent.

DHCP you need add extra option 66 and IP of your PC


#20

User @ranciso gave the simplest solution way above here. Disable LLDP. On a GXP1625, you will find that near the bottom of the Network > Advanced Settings page in the Web UI.

When my phone is stuck in the “recovery incomplete” screen, I remove power and restore it to reboot the phone. After the reboot, I have a few minutes before it tries a firmware update, which is enough time to go into the admin web UI and fiddle with settings.

After I disabled LLDP and rebooted the phone, it successfully upgraded from 1.0.2.4 to 1.0.2.22 from my local tftp server. (I had already set that up while trying to figure things out.)

I then changed to get updates over HTTP via “firmware.grandstream.com”. After another couple reboots, the phone didn’t upgrade again. (Maybe it’s waiting for some schedule to come around?) I put a copy of the lastest firmware, 1.0.4.88, on my tftp server and told the phone to get it from there. It fetched it within a couple of minutes of rebootiing and applied the upgrade.

In case anyone is wondering, my TFTP server is a fairly vanilla Linux machine that I use for various purposes on my local network. Nothing especially special about it. I can see from the TFTP logs that the phone still inquires about configuration things from the TFTP server, even though it’s not configured for that on the phone.