Recovery incomplete on a static ip phone


#1

Hello there,

I’ve been having issues with a couple of GXP-1600 phones which I believe attempted to do a firmware upgrade but failed.

I had to deal with other phones like these but setting them up with TFTPD worked like a charm, however, this time around the phones aren’t able to boot.

The problem is as follows: when the screen turns on after plugging in the phone, it reads “Firmware Upgrade - Initializing…” for about 10 seconds and then switches to just “Firmware Upgrade”. A minute or so later, “Recovery Incomplete” comes up and nothing else.

So, I was told that these phones where set up with a static IPv4 address with no dns server assigned. So, I set up a LAN and used WireShark to find out where are these phones looking for an upgrade. However, it seems like they were configured to skip firmware updates check, because unlike other phones I worked with, which did query a domain name for updates, all these do is look for an IPv6 address.

I set up a DHCPv6 server with Dibbler with options 66/67 pointing to TFTPD with domain fm.grandstream.com/gs. Also, a DNS server with Technitium which had A/AAAA records for fm.grandstream.com/gs pointing to a xampp server listening on port 80 and 443.
This worked like a charm as I could consume all of these services from a client pc, but it doesn’t seem to me like these phones look up DHCPv6 for options 66/67, sadly.

I had the IP the phone had set up before this catastrophe so I tried to log in through ssh port 22 and to my contempt, PuTTy asked for my login details! However as soon as I logged in successfully, the console closes with no message or alert.

I tried to do the same thing through telnet port 23 but I get a “network error: connection refused” message.

Accessing the Web UI just returns ERR_CONNECTION_REFUSED on Chrome, too.

All I can really do right now is ping the IP address and get a response.

I also tried to boot up the phones with no Ethernet cable attached, as I’m using a power pack to power the phones, but no luck.

Hopefully there’s something I’m missing, but for now that’s all I can think after lurking the forums for answers. Please help.

Sincerely,
Miguel


#2

Use firmware.grandstream.com instead of what you have.


#3

Thanks for your reply, no luck though.

Here’s a link to a document with my findings so far, most intriguing however is the following:

image

I can’t seem to pinpoint what I’m doing wrong, it just doesn’t seem to me like the phone is trying to do a firmware upgrade at all. :confounded:


#4

If it have skip firmware it will not start upgrade at all. I do not see any way to upgrade this one as 66/67 only change server but not start.


#5

Thanks for your reply. Is there no way of factory resetting the phone without the web ui or the phone ui? Like, pressing a certain button combination when booting up or something.


#6

Try powering down the unit. Then power back up and when the “booting” message appears, immediately press the 1, 3 & 9 keys down simultaneously and hold until the factory reboot message appears then let up.


#7

Thanks for your reply! I can confirm that pressing 1 and 9 when the booting message appears will perform a factory reset, as I tested this in a working phone. However, the phones I’m having trouble with never exhibit said booting message. On these phones, when the screen lights up for the first time, it reads “Firmware Update - Initializing”. After a little while, it changes to just “Firmware Update” and a bit later, “Recovery Incomplete”, but never a “Booting” message, sadly.

Edit: For clarification, I did try pressing 1 and 9 on the phones presenting Firmware Update - Initializing, but nothing changed, to my dismay.


#8

I can only suggest trying the update from a different location in the off chance some network issue or submitting a ticket.


#9

Well I have had the same exact problem with a 1625 I did submit a ticket and I was told to run wireshack and record a trace which I did and sent back to my dismay I was told the phone was defective that I should RMA. Surprisingly when I powered the phone today it passed all this I even accessed the web but forgot to uncheck firmware when I restarted the phone it’s again back to recovery incomplete.